Bug 1006906 - Repository clone doesn't validate URL
Repository clone doesn't validate URL
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Alexandre Porcelli
Tomas Livora
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-11 09:32 EDT by Eric D. Schabell
Modified: 2014-08-06 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cryptic pop-up screenshot (56.06 KB, image/png)
2013-09-11 09:32 EDT, Eric D. Schabell
no flags Details

  None (edit)
Description Eric D. Schabell 2013-09-11 09:32:35 EDT
Created attachment 796377 [details]
cryptic pop-up screenshot

Description of problem:
When cloning a project into the BizCentral UI, the field Git URL is not validated. The product and user would benefit from validation before trying to submit a clone request that fails and leaves you with a blank entry.

Version-Release number of selected component (if applicable):
ER2

How reproducible:
See above.

Steps to Reproduce:
1. clone repo
2. put in fake url
3. see attached screenshot of cryptic error popup and additional log errors in Additional info below.

Actual results:


Expected results:


Additional info:
09:29:01,566 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
09:29:01,567 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.io.ConversationalEndpointCallback.callback(ConversationalEndpointCallback.java:132)
09:29:01,568 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.io.RemoteServiceCallback.callback(RemoteServiceCallback.java:54)
09:29:01,568 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.cdi.server.CDIExtensionPoints$3.callback(CDIExtensionPoints.java:512)
09:29:01,568 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.client.framework.DeliveryPlan.deliver(DeliveryPlan.java:43)
09:29:01,568 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.ServerMessageBusImpl.sendGlobal(ServerMessageBusImpl.java:632)
09:29:01,568 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.SimpleDispatcher.dispatchGlobal(SimpleDispatcher.java:46)
09:29:01,569 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:93)
09:29:01,569 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:107)
09:29:01,569 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.servlet.DefaultBlockingServlet.doPost(DefaultBlockingServlet.java:117)
09:29:01,569 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
09:29:01,569 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
09:29:01,570 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)
09:29:01,570 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
09:29:01,570 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.solder.servlet.exception.CatchExceptionFilter.doFilter(CatchExceptionFilter.java:65)
09:29:01,570 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246)
09:29:01,570 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
09:29:01,571 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.solder.servlet.event.ServletEventBridgeFilter.doFilter(ServletEventBridgeFilter.java:74)
09:29:01,571 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246)
09:29:01,571 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
09:29:01,571 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jbpm.designer.web.filter.impl.PluggableFilter.doFilter(PluggableFilter.java:70)
09:29:01,571 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246)
09:29:01,572 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
09:29:01,572 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.security.server.UberFireSecurityFilter.doFilter(UberFireSecurityFilter.java:254)
09:29:01,572 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246)
09:29:01,572 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
09:29:01,572 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
09:29:01,573 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)
09:29:01,573 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:481)
09:29:01,573 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50)
09:29:01,573 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50)
09:29:01,573 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
09:29:01,573 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
09:29:01,574 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
09:29:01,574 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
09:29:01,574 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
09:29:01,574 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
09:29:01,574 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653)
09:29:01,574 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
09:29:01,575 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at java.lang.Thread.run(Thread.java:722)
09:29:01,575 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) Caused by: java.lang.RuntimeException: org.eclipse.jgit.api.errors.InvalidRemoteException: Invalid remote: origin
09:29:01,575 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.commons.java.nio.fs.jgit.util.JGitUtil.cloneRepository(JGitUtil.java:231)
09:29:01,575 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.commons.java.nio.fs.jgit.JGitFileSystemProvider.newFileSystem(JGitFileSystemProvider.java:459)
09:29:01,576 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.commons.java.nio.file.FileSystems.newFileSystem(FileSystems.java:117)
09:29:01,576 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.commons.java.nio.file.FileSystems.newFileSystem(FileSystems.java:83)
09:29:01,576 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.commons.io.impl.AbstractIOService.newFileSystem(AbstractIOService.java:163)
09:29:01,576 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.kieora.io.IOServiceIndexedImpl.newFileSystem(IOServiceIndexedImpl.java:123)
09:29:01,576 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.commons.io.impl.AbstractIOService.newFileSystem(AbstractIOService.java:152)
09:29:01,577 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.kieora.io.IOServiceIndexedImpl.newFileSystem(IOServiceIndexedImpl.java:99)
09:29:01,577 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.backend.server.repositories.git.GitRepositoryFactoryHelper.newRepository(GitRepositoryFactoryHelper.java:72)
09:29:01,577 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.backend.server.repositories.git.GitRepositoryFactoryHelper$Proxy$_$$_WeldClientProxy.newRepository(GitRepositoryFactoryHelper$Proxy$_$$_WeldClientProxy.java)
09:29:01,577 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.backend.server.repositories.RepositoryFactoryImpl.newRepository(RepositoryFactoryImpl.java:36)
09:29:01,577 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.backend.server.repositories.RepositoryFactoryImpl$Proxy$_$$_WeldClientProxy.newRepository(RepositoryFactoryImpl$Proxy$_$$_WeldClientProxy.java)
09:29:01,577 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.backend.server.repositories.RepositoryServiceImpl.createRepository(RepositoryServiceImpl.java:132)
09:29:01,578 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.backend.server.repositories.RepositoryServiceImpl.createRepository(RepositoryServiceImpl.java:123)
09:29:01,578 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.uberfire.backend.server.repositories.RepositoryServiceImpl$Proxy$_$$_WeldClientProxy.createRepository(RepositoryServiceImpl$Proxy$_$$_WeldClientProxy.java)
09:29:01,578 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
09:29:01,578 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
09:29:01,578 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
09:29:01,578 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at java.lang.reflect.Method.invoke(Method.java:601)
09:29:01,579 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.io.ConversationalEndpointCallback.callback(ConversationalEndpointCallback.java:114)
09:29:01,579 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	... 38 more
09:29:01,579 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) Caused by: org.eclipse.jgit.api.errors.InvalidRemoteException: Invalid remote: origin
09:29:01,579 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:134)
09:29:01,579 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.api.CloneCommand.fetch(CloneCommand.java:178)
09:29:01,580 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.api.CloneCommand.call(CloneCommand.java:125)
09:29:01,580 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.kie.commons.java.nio.fs.jgit.util.JGitUtil.cloneRepository(JGitUtil.java:215)
09:29:01,580 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	... 57 more
09:29:01,580 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) Caused by: org.eclipse.jgit.errors.NoRemoteRepositoryException: http://www.schabell.org/fun.git: http://www.schabell.org/fun.git/info/refs?service=git-upload-pack not found
09:29:01,580 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:465)
09:29:01,581 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:305)
09:29:01,581 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
09:29:01,581 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
09:29:01,581 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1104)
09:29:01,581 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:128)
09:29:01,581 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) 	... 60 more
09:29:01,582 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) *** Message delivery failure ***
09:29:01,582 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) Bus: org.jboss.errai.bus.server.ServerMessageBusImpl@37698ff2
09:29:01,582 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) Message: CommandType=createRepository:java.lang.String:java.lang.String:java.util.Map:, ErrorTo=org.uberfire.backend.repositories.RepositoryService:RPC.createRepository:java.lang.String:java.lang.String:java.util.Map::Errors:15, ReplyTo=org.uberfire.backend.repositories.RepositoryService:RPC.createRepository:java.lang.String:java.lang.String:java.util.Map::RespondTo:15, ToSubject=org.uberfire.backend.repositories.RepositoryService:RPC, MethodParms=[git, testvalidateurl, {username=, origin=http://www.schabell.org/fun.git, crypt:password=}]
09:29:01,582 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) errorMessage: Error calling remote service: org.uberfire.backend.repositories.RepositoryService:RPC
09:29:01,582 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) exception: org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
09:29:01,582 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) disconnect: false
Comment 2 Alexandre Porcelli 2013-09-17 10:34:52 EDT
Fixed on UberFire  master and 0.3.x branches:

https://github.com/droolsjbpm/uberfire/commit/02f718600
https://github.com/droolsjbpm/uberfire/commit/f88cdcdb0
Comment 4 Tomas Livora 2013-10-16 05:05:25 EDT
Verified on BPMS 6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.