Bug 1006908 - Met error "[: : unary operator expected" when git push nodejs apps with hot deploy marker.
Met error "[: : unary operator expected" when git push nodejs apps with hot d...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fotios Lindiakos
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 09:32 EDT by Liang Xia
Modified: 2015-05-14 19:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:50:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Xia 2013-09-11 09:32:58 EDT
Description of problem:
Met error "[: : unary operator expected" when git push nodejs apps with hot deploy marker.

Version-Release number of selected component (if applicable):
devenv_3772

How reproducible:
always

Steps to Reproduce:
1.create a nodejs app
2.add hot_deploy marker
3.do some change and git push the change
4.check the output of git push

Actual results:
# git add .; git commit -amp ; git push
Counting objects: 3, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (2/2), 247 bytes, done.
Total 2 (delta 1), reused 0 (delta 0)
remote: Not stopping cartridge haproxy because hot deploy is enabled
remote: Not stopping cartridge nodejs because hot deploy is enabled
remote: hot_deploy marker found. Switching to using supervisor. Subsequent pushes won't require restart until the marker is removed.
remote: Saving away previously installed Node modules
remote: Building NodeJS cartridge
remote: npm info it worked if it ends with ok
remote: npm info using npm@1.1.37
remote: npm info using node@v0.6.20
remote: npm info preinstall OpenShift-Sample-App@1.0.0
remote: npm info build /var/lib/openshift/522fe1891260210aa5000039/app-root/runtime/repo
remote: npm info linkStuff OpenShift-Sample-App@1.0.0
remote: npm info install OpenShift-Sample-App@1.0.0
remote: npm info postinstall OpenShift-Sample-App@1.0.0
remote: npm info ok 
remote: Starting application nodejs06s
remote: Not starting cartridge haproxy because hot deploy is enabled
remote: Application will not be stopped during gear sync to to presence of hot_deploy marker
remote: Not starting cartridge nodejs because hot deploy is enabled
remote: hot_deploy marker found. Switching to using supervisor. Subsequent pushes won't require restart until the marker is removed.
remote: Stopping NodeJS cartridge
remote: /var/lib/openshift/522fe1891260210aa5000039/nodejs/bin/control: line 147: [: : unary operator expected
remote: usage: kill [ -s signal | -p ] [ -a ] pid ...
remote:        kill -l [ signal ]
remote: Starting NodeJS cartridge
To ssh://522fe1891260210aa5000039@nodejs06s-migration2.dev.rhcloud.com/~/git/nodejs06s.git/
   520de9d..0e85055  master -> master


Expected results:
Git push successfully without errors.

Additional info:
https://github.com/openshift/origin-server/blob/master/cartridges/openshift-origin-cartridge-nodejs/bin/control
Comment 1 Fotios Lindiakos 2013-09-11 14:52:15 EDT
Related to: Bug1006355, Bug1006701

Fixed in https://github.com/openshift/origin-server/pull/3619
Comment 2 Liang Xia 2013-09-11 23:34:31 EDT
Verified on devenv_3776, no errors met when git push changes with hot_deploy marker, and changed deployed successfully.


# git add . ; git commit -amp; git push
Counting objects: 9, done.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (5/5), 446 bytes, done.
Total 5 (delta 3), reused 0 (delta 0)
remote: Not stopping cartridge nodejs because hot deploy is enabled
remote: Saving away previously installed Node modules
remote: Building NodeJS cartridge
remote: npm info it worked if it ends with ok
remote: npm info using npm@1.1.37
remote: npm info using node@v0.6.20
remote: npm info preinstall OpenShift-Sample-App@1.0.0
remote: npm info build /var/lib/openshift/523131b16849bb5770000165/app-root/runtime/repo
remote: npm info linkStuff OpenShift-Sample-App@1.0.0
remote: npm info install OpenShift-Sample-App@1.0.0
remote: npm info postinstall OpenShift-Sample-App@1.0.0
remote: npm info ok 
remote: Starting application nj
remote: Not starting cartridge nodejs because hot deploy is enabled
remote: hot_deploy marker found. Switching to using supervisor. Subsequent pushes won't require restart until the marker is removed.
To ssh://523131b16849bb5770000165@nj-lxia.dev.rhcloud.com/~/git/nj.git/
   d826e37..36fd875  master -> master

Note You need to log in before you can comment on or make changes to this bug.