Bug 1006911 - heat-engine requires dependency python-pbr
heat-engine requires dependency python-pbr
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-heat (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 09:41 EDT by stefano.zilli
Modified: 2014-06-05 05:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 10:30:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stefano.zilli 2013-09-11 09:41:08 EDT
Description of problem:
heat-engine package needs python-pbr on runtime but it is not in the package dependencies.

Version-Release number of selected component (if applicable):
openstack-heat-engine 0.5.b3.el6

How reproducible:
100%

Steps to Reproduce:
1. heat-db-setup rpm -y -r xxx --password yyy
2.
3.

Actual results:
Traceback (most recent call last):
  File "/usr/bin/heat-manage", line 32, in <module>
    from heat.cmd import manage
  File "/usr/lib/python2.6/site-packages/heat/cmd/manage.py", line 29, in <module>
    from heat import version
  File "/usr/lib/python2.6/site-packages/heat/version.py", line 17, in <module>
    import pbr.version
ImportError: No module named pbr.version
Comment 1 Steven Hardy 2013-09-16 10:01:27 EDT
Fixed in current version:

# rpm -q --whatrequires python-pbr
openstack-heat-common-2013.2-0.7.b3.fc20.noarch
Comment 2 Alan Pevec 2013-10-11 15:36:27 EDT
So this is confusing, in Fedora you added Requires: python-pbr and in el6-havana you removed it: http://pkgs.fedoraproject.org/cgit/openstack-heat.git/tree/remove-pbr-runtime-dependency.patch?h=el6-havana

It should've been the latter everywhere, we did that in other openstack-* packages.
PBR as runtime dep in Havana is wrong and will be left as a historical anecdote.
Comment 3 Jeff Peeler 2013-10-11 15:53:55 EDT
I did that only because the version of pbr in EPEL wouldn't work. A patch is preferred over adding a dependency?
Comment 4 Alan Pevec 2013-10-14 08:11:40 EDT
(In reply to Jeff Peeler from comment #3)
> A patch is preferred over adding a dependency?

Yes, since that dependency is bogus and is being removed upstream.

Note You need to log in before you can comment on or make changes to this bug.