Bug 100697 - useradd and adduser, no capital letters.
useradd and adduser, no capital letters.
Status: CLOSED DUPLICATE of bug 89677
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
9
i686 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-24 09:55 EDT by Federico Fiordoliva
Modified: 2006-02-21 13:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Federico Fiordoliva 2003-07-24 09:55:52 EDT
Description of problem:
useradd/adduser does not allow the creation of users with capital letters. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:

I would want to continue to create the customers with capital letters
Additional info:
Comment 1 Jeremy Portzer 2003-08-29 15:15:11 EDT
Is there any reason that useradd changed this behavior between Red Hat Linux 8.0
and 9?  As far as I can tell, this is not documented in the release notes, the
useradd man page, or even the --changelog for the shadow-utils package.

POSIX seems to allow user names to be mixed case:
http://www.opengroup.org/onlinepubs/007904975/basedefs/xbd_chap03.html#tag_03_426

It has been traditional in UNIX-like operating systems to allow uppercase
usernames as long as EVERY character isn't an uppercase.  When every character
is an uppercase, the "login" program assumed you're using a terminal that
doesn't support lowercase and would convert all uppercase letters to lowercase.
     But that leaves no reason why a username can't be mixed case.
Comment 2 Barry P Evans 2003-08-29 16:33:01 EDT
This bug was noticed while using IBM Tivoli Identity Manager's (ITIM) Linux
Agent with RedHat 9. The default identity (aka username) generated has been a
users last name which includes capital characters.  Noticed the change in
behaviour when moving the agent from RedHat8 (worked) to RedHat9 (failures). 
Solaris 8 allows for mixed case user names and I would expect that linux would
too. (even if through some legacy flag being configured in /etc)  I know that
mixed case userid's are in bad form but if a shop has mixed case unix id's and
want them to be the same across Unix's & Linux then Linux should allow for it. 
As pointed out, POSIX doesn't claim lowercase only for user names.
Comment 3 Milan Kerslager 2003-10-23 00:42:42 EDT
Capital letters breaks sendmail (unable to deliver message: User unknown). On
classes on university all teachers told to us to not use capital letters in
login name because old Unixes thinks that terminal does not allow small capitals
if first letter of login name is capital. So you can write 'LS' and run 'ls'
even you are unable to write small capitals.

I was working with terminal like this (only capital letters) on university at 1991.

*** This bug has been marked as a duplicate of 89677 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:57:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.