Bug 1006971 - A domain member server cannot list translators
A domain member server cannot list translators
Status: CLOSED WONTFIX
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid, Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Van Halbert
:
Depends On: 982741
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 11:33 EDT by Van Halbert
Modified: 2014-07-09 01:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 21:17:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-2659 Major Closed A domain member server cannot list translators 2014-05-01 19:30:18 EDT

  None (edit)
Comment 1 JBoss JIRA Server 2013-09-13 12:19:17 EDT
Ramesh Reddy <rareddy@jboss.org> made a comment on jira TEIID-2659

Upon some searching and talking BrianS from AS team, it looks like

1) You can only execute "read-only" methods on slave host controllers, any non-read-only must be executed on the master domain controller.

2) I tried making operations like "list-translators" as read-only, but it is executed on the host-controller it will not be forwarded to actual servers so you will not get the desired results.

3) One option is to re-write Admin Domain layer, such that the request is manually submitted to each server node in the domain and then collate the results, however, what I have observed while testing is, only when user is connected to the master domain controller you can query about all hosts in the domain. When user is connected to slave host controller, they can see only server nodes under that controller, thus invalidates that option.

4) Also in domain mode you have to connect to master domain controller to do any deployments.

Given all the restrictions, there is no good way to fix this issue, unless AS7 code is fixed to allow some of the features. Thus my recommendation is to reject this issue and have tools like Designer and AdminShell only connect to the master domain controller for issuing any Teiid Admin operations.
Comment 2 JBoss JIRA Server 2013-09-20 13:14:05 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2659

Paul do you agree with Ramesh, or does something need to be raised with Brian?
Comment 3 JBoss JIRA Server 2013-09-20 16:43:32 EDT
Paul Richardson <p.g.richardson@phantomjinx.co.uk> made a comment on jira TEIID-2659

I do agree. JBT does not support domain mode explicitly and until their use cased are functionally fleshed out then I don't see an alternative.
Comment 4 JBoss JIRA Server 2013-09-20 16:58:02 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-2659 to Resolved
Comment 8 belong 2013-11-05 21:56:30 EST
Since this was included in Beta release notes, I should probably make not of it in GA release notes.
Comment 9 JBoss JIRA Server 2013-12-05 08:56:01 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2659 to Closed

Note You need to log in before you can comment on or make changes to this bug.