Bug 1006979 - horizon [Havana]: Block Device Mapping is Invalid: failed to get volume when trying to boot an instance from a volume from horizon
horizon [Havana]: Block Device Mapping is Invalid: failed to get volume when ...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: RC
: Havana
Assigned To: Xavier Queralt
Gabriel Szasz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 11:51 EDT by Dafna Ron
Modified: 2014-06-18 03:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.23.rc1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-24 03:45:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (150.95 KB, application/x-gzip)
2013-09-11 11:51 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1220814 None None None Never
OpenStack gerrit 46221 None None None Never

  None (edit)
Description Dafna Ron 2013-09-11 11:51:07 EDT
Created attachment 796446 [details]
logs

Description of problem:

i tried to launch an instance from volume from horizon and we are failing with a mapping error. 

Version-Release number of selected component (if applicable):

python-django-horizon-2013.2-0.10b3.el6.noarch

How reproducible:

100%

Steps to Reproduce:
1. install AIO with havana with local tgt 
2. create a volume 
3. try to launch an instance from the volume using horizon 

Actual results:

we fail to launch the instance 

Expected results:

we should be able to launch the instance

Additional info: logs

[root@nott-vdsa ~(keystone_admin)]# egrep 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62 /var/log/*/*
/var/log/horizon/horizon.log:Recoverable error: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62. (HTTP 400) (Request-ID: req-64a2cdee-6c76-4bb5-a4d8-0a2bf935e4da)
/var/log/horizon/horizon.log:Recoverable error: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62. (HTTP 400) (Request-ID: req-24f8e28e-8e18-452a-9373-10e903d8a9c9)
/var/log/horizon/horizon.log:Recoverable error: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62. (HTTP 400) (Request-ID: req-3a3891f6-e489-41e9-bd1b-8dad63a8bfc8)
/var/log/httpd/access_log:10.32.224.231 - - [11/Sep/2013:16:20:19 +0300] "GET /dashboard/project/volumes/?action=row_update&table=volumes&obj_id=2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62 HTTP/1.1" 200 577 "http://nott-vdsa.qa.lab.tlv.redhat.com/dashboard/project/volumes/" "Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130619 Firefox/17.0"
/var/log/nova/api.log:2013-09-11 16:32:52.772 19836 DEBUG nova.api.openstack.wsgi [req-64a2cdee-6c76-4bb5-a4d8-0a2bf935e4da 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] Action: 'create', body: {"server": {"name": "dafna", "imageRef": "", "block_device_mapping": [{"volume_id": "2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62", "delete_on_termination": "0", "device_name": "vda"}], "flavorRef": "1", "max_count": 1, "min_count": 1, "security_groups": [{"name": "default"}]}} _process_stack /usr/lib/python2.6/site-packages/nova/api/openstack/wsgi.py:935
/var/log/nova/api.log:2013-09-11 16:32:52.939 19836 DEBUG urllib3.connectionpool [-] "GET /v1/532307bfce18431ba50d309622619b66/volumes/2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62 HTTP/1.1" 200 546 _make_request /usr/lib/python2.6/site-packages/urllib3/connectionpool.py:295
/var/log/nova/api.log:2013-09-11 16:32:52.949 19836 INFO nova.api.openstack.wsgi [req-64a2cdee-6c76-4bb5-a4d8-0a2bf935e4da 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] HTTP exception thrown: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62.
/var/log/nova/api.log:2013-09-11 16:32:52.977 19836 DEBUG nova.api.openstack.wsgi [req-64a2cdee-6c76-4bb5-a4d8-0a2bf935e4da 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] Returning 400 to user: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62. __call__ /usr/lib/python2.6/site-packages/nova/api/openstack/wsgi.py:1198
/var/log/nova/api.log:2013-09-11 16:33:18.632 19829 DEBUG nova.api.openstack.wsgi [req-24f8e28e-8e18-452a-9373-10e903d8a9c9 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] Action: 'create', body: {"server": {"name": "dafba", "imageRef": "", "block_device_mapping": [{"volume_id": "2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62", "delete_on_termination": "0", "device_name": "vda"}], "flavorRef": "1", "max_count": 1, "min_count": 1, "security_groups": [{"name": "default"}]}} _process_stack /usr/lib/python2.6/site-packages/nova/api/openstack/wsgi.py:935
/var/log/nova/api.log:2013-09-11 16:33:18.794 19829 DEBUG urllib3.connectionpool [-] "GET /v1/532307bfce18431ba50d309622619b66/volumes/2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62 HTTP/1.1" 200 546 _make_request /usr/lib/python2.6/site-packages/urllib3/connectionpool.py:295
/var/log/nova/api.log:2013-09-11 16:33:18.804 19829 INFO nova.api.openstack.wsgi [req-24f8e28e-8e18-452a-9373-10e903d8a9c9 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] HTTP exception thrown: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62.
/var/log/nova/api.log:2013-09-11 16:33:18.804 19829 DEBUG nova.api.openstack.wsgi [req-24f8e28e-8e18-452a-9373-10e903d8a9c9 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] Returning 400 to user: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62. __call__ /usr/lib/python2.6/site-packages/nova/api/openstack/wsgi.py:1198
/var/log/nova/api.log:2013-09-11 18:29:31.216 19832 DEBUG nova.api.openstack.wsgi [req-3a3891f6-e489-41e9-bd1b-8dad63a8bfc8 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] Action: 'create', body: {"server": {"name": "bla", "imageRef": "", "block_device_mapping": [{"volume_id": "2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62", "delete_on_termination": "0", "device_name": "vda"}], "flavorRef": "1", "max_count": 1, "min_count": 1, "security_groups": [{"name": "default"}]}} _process_stack /usr/lib/python2.6/site-packages/nova/api/openstack/wsgi.py:935
/var/log/nova/api.log:2013-09-11 18:29:31.381 19832 DEBUG urllib3.connectionpool [-] "GET /v1/532307bfce18431ba50d309622619b66/volumes/2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62 HTTP/1.1" 200 546 _make_request /usr/lib/python2.6/site-packages/urllib3/connectionpool.py:295
/var/log/nova/api.log:2013-09-11 18:29:31.392 19832 INFO nova.api.openstack.wsgi [req-3a3891f6-e489-41e9-bd1b-8dad63a8bfc8 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] HTTP exception thrown: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62.
/var/log/nova/api.log:2013-09-11 18:29:31.418 19832 DEBUG nova.api.openstack.wsgi [req-3a3891f6-e489-41e9-bd1b-8dad63a8bfc8 0007c2f5563c4cc883c0c8d9e7f7d6f8 532307bfce18431ba50d309622619b66] Returning 400 to user: Block Device Mapping is Invalid: failed to get volume 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62. __call__ /usr/lib/python2.6/site-packages/nova/api/openstack/wsgi.py:1198
[root@nott-vdsa ~(keystone_admin)]# cinder list
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| 2d16a3cd-a29f-4d9b-858a-b2e0eb6dec62 | available |    dafna     |  10  |     None    |  False   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
Comment 2 Xavier Queralt 2013-09-12 04:14:25 EDT
This bug is in the nova side. It is failing because the volume has not been created from an image and, hence, has no image_metadata.

See upstream bug: https://bugs.launchpad.net/nova/+bug/1220814

Moving this to nova component, I'll propose a fix upstream briefly.

Note You need to log in before you can comment on or make changes to this bug.