Bug 10070 - double copy of lpd
double copy of lpd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-08 14:00 EST by Levente
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-02 09:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Levente 2000-03-08 14:00:52 EST
The default lpd is running double copy of itself. If I kill both of them
and restart by using /etc/rc.d/init.d/lpr start, it happens again.
This is only a part of the story since lpd doesn't work at all.
I use it with a remote printer with a fixed IP number.
I can delete the full printer record and rewrite it again by using
printool (deleting /var/spool/lpd/lp...), restarting it with no effect.
I don't know how to debug the problem but I guess there must be something
inherent either in deamon script or lpr

Levente Torok
Comment 1 Jeff Johnson 2000-03-10 09:25:59 EST
A new instance of lpd is fork'ed for every print request.
What does "lpc status" say when you see the problem?
Comment 2 grtodd 2000-04-27 17:49:59 EDT
I think 10070 depends on 9084.  Clearing the queue seems to fix things for me
with various versions of the lpr "component". I'm not sure if clearing the print
queue on a reboot is "the right thing to do" in Unix networking - clearing the
mail queue sure wouldn't be!
Comment 3 paul.knowles 2000-05-02 09:57:59 EDT
This `double copy' seems to be the way that lpd verifies the contents of the
printcap file.  BUT, if there is one inaccessable remote printer in the printcap
file, the spanned lpd process looking for the remote printer blocks and never
returns to the parent.  Just kill the process that is in the state nanosleep (do
a ps on the two process numbers, one will be wait4, the other nanos).   After
this kill, all the printers in the printcap file seem to be correctly behaved.
Comment 4 Bernhard Rosenkraenzer 2000-06-16 06:18:37 EDT
This is fixed in the current version.

Note You need to log in before you can comment on or make changes to this bug.