Bug 1007001 - Upgrade remoting-jmx to 1.1.1.Final
Upgrade remoting-jmx to 1.1.1.Final
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JMX (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: EAP 6.2.0
Assigned To: Darran Lofthouse
:
Depends On:
Blocks: 999622 1009762
  Show dependency treegraph
 
Reported: 2013-09-11 13:09 EDT by Kabir Khan
Modified: 2013-12-15 11:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker REMJMX-68 Major Resolved ClientConnection should propagate JMRuntimeException 2013-12-16 04:01:38 EST
JBoss Issue Tracker REMJMX-72 Major Resolved Release Remoting JMX 1.1.1.Final 2013-12-16 04:01:38 EST

  None (edit)
Description Kabir Khan 2013-09-11 13:09:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Darran Lofthouse 2013-09-11 13:12:19 EDT
Although may go straight to Final
Comment 2 Rostislav Svoboda 2013-09-12 04:48:46 EDT
Ack - related to JMX Rbac
Comment 3 JBoss JIRA Server 2013-09-12 07:37:16 EDT
Darran Lofthouse <darran.lofthouse@jboss.com> updated the status of jira REMJMX-68 to Resolved
Comment 4 JBoss JIRA Server 2013-09-12 17:42:49 EDT
Kabir Khan <kabir.khan@jboss.com> made a comment on jira REMJMX-68

Discussing with Brian we decided this should be its superclass instead.
Comment 5 JBoss JIRA Server 2013-09-12 17:44:47 EDT
Kabir Khan <kabir.khan@jboss.com> made a comment on jira REMJMX-68

Discussing with Brian we decided that the client should propagate JMRuntimeException rather than RuntimeMBeanException. The reason is JMRuntimeException is the parent for a bunch of useful exceptions, and JMRuntimeException itself does not require a cause in the constructor.
Comment 6 JBoss JIRA Server 2013-09-13 05:19:15 EDT
Darran Lofthouse <darran.lofthouse@jboss.com> updated the status of jira REMJMX-68 to Reopened
Comment 7 JBoss JIRA Server 2013-09-13 09:00:00 EDT
Darran Lofthouse <darran.lofthouse@jboss.com> updated the status of jira REMJMX-68 to Resolved
Comment 8 JBoss JIRA Server 2013-09-18 15:44:43 EDT
Darran Lofthouse <darran.lofthouse@jboss.com> updated the status of jira REMJMX-72 to Resolved
Comment 10 Ladislav Thon 2013-09-30 06:20:18 EDT
Given that bug 1009762 is already verified, I think we can move this to the "verified" state too, even though the non-productized remoting-jmx 1.1.1 version has never made it to any EAP 6.2.0.ERx.

Note You need to log in before you can comment on or make changes to this bug.