This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1007002 - RFE: Add a python3 mod_wsgi package
RFE: Add a python3 mod_wsgi package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_wsgi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 13:10 EDT by Luke Macken
Modified: 2016-09-19 22:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: mod_wsgi-3.4-11.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 11:29:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2013-09-11 13:10:49 EDT
mod_wsgi version 3.0 and later supports Python 3.1 and later:

http://code.google.com/p/modwsgi/wiki/SupportForPython3X
http://code.google.com/p/modwsgi/wiki/ChangesInVersion0300
Comment 1 Luke Macken 2013-09-11 13:12:55 EDT
CC'ing Jim Minter, who has done some work on the mod_wsgi-python3 subpackage: https://github.com/jim-minter/mod_wsgi
Comment 2 Luke Macken 2013-09-11 13:16:49 EDT
A couple of things stand out with the spec changes:

The following was removed from %build, which may cause problems:

-# Regenerate configure for -coredump patch change to configure.in
-autoconf

Also, the --with-python=%__python3 should probably be %{__python3} to remain consistent.

Other than that, it looks good at a first glance, but I have yet to actually test it.
Comment 3 Jim Minter 2013-09-12 17:44:04 EDT
Luke, thanks for setting up this bz.

The autoconf removal from %build is because I propose to just apply the vanilla upstream patches as-is.  These directly patch ./configure and ./configure.ac (see mod_wsgi-3.4-1002-core-dumps.patch) whereas for some reason the current Fedora mod_wsgi patchsets omit these diffs.  By using the upstream patches direct I believe that the autoconf line is surplus to requirements and therefore I removed it.  If I'm wrong / if there's doubt / if I'm told to, I can put it back in?

I've fixed the suggested addition of braces (%{__python3}) -- thanks; please pull.
Comment 4 Luke Macken 2013-09-13 11:53:34 EDT
Excellent, looks good! I just tested your mod_wsgi-python3 subpackage with a basic Pyramid quickstart and it worked as expected.
Comment 5 Jim Minter 2013-09-25 08:45:43 EDT
Great - what next?
Comment 6 Luke Macken 2013-10-01 17:20:27 EDT
Assuming the mod_wsgi and httpd maintainers don't see any problems with it, getting it into rawhide would be the next step (then f20?). It may also be worth dropping a line to the python-devel list announcing it and asking for more testers. https://lists.fedoraproject.org/mailman/listinfo/python-devel
Comment 7 Matthias Runge 2014-01-14 11:29:35 EST
I'm very sorry for delaying this. 

It's now been fixed in 
mod_wsgi-3.4-11.fc21

Note You need to log in before you can comment on or make changes to this bug.