Bug 1007058 - Remove default linkage to ATLAS in gsl
Remove default linkage to ATLAS in gsl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gsl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 15:56 EDT by Susi Lehtola
Modified: 2015-02-21 17:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-15 16:21:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2013-09-11 15:56:28 EDT
Hi,


I'm the reason why GSL is nowadays linked with ATLAS. However, I've realized since that the GSL library is not linked by default to a CBLAS library just because upstream wants this option to be left to the user
 http://www.gnu.org/software/gsl/manual/html_node/Linking-with-an-alternative-BLAS-library.html

Now that there is actually a better BLAS library in Fedora, namely OpenBLAS, I'd recommend returning gsl to the original state of requiring the specification of a CBLAS library at link time.
Comment 1 Susi Lehtola 2014-02-15 16:07:12 EST
Ping, any progress?

I can address this myself.
Comment 2 Jerry James 2015-02-21 16:25:23 EST
This change broke opengrm-ngram.  It now has undefined symbols at runtime.  In fact, this change will have broken lots of (if not all) gsl-using libraries and applications.  At the very least, maintainers of all affected packages should have been notified of this change.  Even better would have been a rebuild of all affected programs to find out which ones would break.

In my opinion, this change should be announced on fedora-devel immediately, with follow up emails or bugs filed against all affected packages.
Comment 3 Susi Lehtola 2015-02-21 17:49:05 EST
Good suggestion, on it.

Note You need to log in before you can comment on or make changes to this bug.