Bug 100706 - vncserver service never executes /etc/profile
vncserver service never executes /etc/profile
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-24 10:22 EDT by Richard Faasen
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version: 4.0-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 12:23:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Faasen 2003-07-24 10:22:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
When vncserver is setup and started with the "service vncserver start" command,
the scripts /etc/profile and ~/.bash_profile are never executed. This results in
some variables not set. In my case, because INPUTRC is unset, the delete key
does not work properly (tilde~). After making some changes in
/etc/init.d/vncserver (source /etc/profile ; source ~/.bash_profile   at the su
line) the variables were again set properly and delete key works as expected.

This does not solve the same problem for the tsch shell. When I start a tsch
shell in the remote vnc client, the delete key produces ~ and the INPUTRC
variable is not set.


Version-Release number of selected component (if applicable):
3.3.3r2-47

How reproducible:
Always

Steps to Reproduce:
1. Setup vncserver, then: service vncserver start
2. From remote machine connect to the vnc server
3. In a terminal window: echo $INPUTRC, use the DELETE key.
    

Actual Results:  $INPUTRC is empty. Delete key produces a tilde~.

Expected Results:  I would expect $INPUTRC be set and the delete key to work
properly as they are set in /etc/profile. This script should have ran at some point.

Additional info:

The /etc/profile script is started upon logon, and by starting vnc this way you
are not logging on, so profile is not started. So strictly speaking what happens
is correct behaviour. But /etc/profile usually contains stuff that is needed and
has to be run at some point. I have not tried the -l option with su, but I think
it will not solve the problem with both bash and tsch at the same time. The
above is a work-around that works fine for me.
Comment 1 Tim Waugh 2004-12-10 12:23:26 EST
This is now fixed.

Note You need to log in before you can comment on or make changes to this bug.