Bug 1007064 - httpd-2.4.6-2.fc19.armv7hl: error: unpacking of archive failed on file /usr/sbin/suexec: cpio: cap_set_file
httpd-2.4.6-2.fc19.armv7hl: error: unpacking of archive failed on file /usr/s...
Status: CLOSED DUPLICATE of bug 648654
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
19
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 16:19 EDT by Martijn Ras
Modified: 2014-05-07 04:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-07 04:22:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martijn Ras 2013-09-11 16:19:39 EDT
Description of problem:
httpd-2.4.6-2.fc19.armv7hl fails to install with:
error: unpacking of archive failed on file /usr/sbin/suexec: cpio: cap_set_file

Version-Release number of selected component (if applicable): 2.4.6-2

How reproducible:
Always

Steps to Reproduce:
1. yum install httpd

Actual results:
Running transaction
  Installing : httpd-2.4.6-2.fc19.armv7hl
Error unpacking rpm package httpd-2.4.6-2.fc19.armv7hl
error: unpacking of archive failed on file /usr/sbin/suexec: cpio: cap_set_file
  Verifying  : httpd-2.4.6-2.fc19.armv7hl

Failed:
  httpd.armv7hl 0:2.4.6-2.fc19

Expected results:
httpd installed on system

Additional info:
Comment 1 Martijn Ras 2013-09-14 07:13:49 EDT
This seems to be similar to what is described in this bug: #648654

However, here it crashed while installing on the EXT4 root (/) partition on disk.
There's no NFS on my computer.

I tried chmod u+s /usr/sbin/suexec and installing the package again, same result.
Comment 2 Martijn Ras 2013-09-14 08:10:20 EDT
Just did an update of the system to see if this would go away ...

It now fails with the same error on:

/usr/sbin/mtr mtr-0.84-2.fc19.armv7hl
/usr/sbin/rcp rsh-0.17-72.fc19.armv7hl
/usr/bin/systemd-detect-virt systemd-204-9.fc19.armv7hl

So i've moved this from the httpd component to the rpm component.

The EXT4 root (/) partition is on eMMC disk, mounted as follows:

/dev/mmcblk0p3 on / type ext4 (rw,noatime,data=ordered)
Comment 3 Martijn Ras 2013-09-14 09:11:24 EDT
I now think this has to do with the kernel version, 3.8.13 on my ODROID-X2 system.

I found there's a script to update the kernel, but in it's current form that does not work. Got no more spare time today, i'll continue tomorrow.
Comment 4 Martijn Ras 2013-11-05 13:51:41 EST
Finally had some spare time to dive into this again.

The problem is that SELinux is disabled in the kernel (version 3.8.13) on my ODROID-X2 system. When I removed the %caps from the following line in the mtr.spec file the package installed without any problems:

%caps(cap_net_raw=pe) %{_sbindir}/mtr
Comment 5 Panu Matilainen 2014-05-07 04:22:00 EDT
I'm sure its possible to build a kernel in plenty of ways that break various assumptions Fedora packages (legally) make, but that's a case of "you broke so you keep to get the pieces". Here the bigger question is: should rpm fallback to SUID if capabilities are not supported by a particular filesystem or system in general -> dupe of 648654.

*** This bug has been marked as a duplicate of bug 648654 ***

Note You need to log in before you can comment on or make changes to this bug.