Bug 1007108 - Process Blocks in documents no longer render.
Process Blocks in documents no longer render.
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
Jared MORGAN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 19:01 EDT by Jared MORGAN
Modified: 2015-08-09 21:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 06:37:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared MORGAN 2013-09-11 19:01:24 EDT
Description of problem:

In http://topika.ecs.eng.bne.redhat.com:8080/pressgang-ccms-ui-next/#ContentSpecFilteredResultsAndContentSpecView;query;contentSpecIds=16459, the process block no longer has Prev and Next topic flow navigation.

    Process: JBoss Portal as the Identity Provider (IDP) and Google Apps as the Service Provider (SP)
      IDP (JBoss Portal) and SP (Google Apps) Prerequisites [16674]
      Create A Google Apps for Business Account [22474]
      Create Default Google Apps for Business Users [22475]
      Configuring Google Apps as the SP [16686]
      Configuring JBoss Portal as the IDP [16673]
      Testing the IDP (JBoss Portal) and SP (Google Apps) Configuration [16685]
        [Prerequisite:
          Configuring Google Apps as the SP [16686],
          Configuring JBoss Portal as the IDP [16673]]


Version-Release number of selected component (if applicable):


How reproducible:

100%


Steps to Reproduce:

1. View the published book for the spec at http://docbuilder.usersys.redhat.com/16459/remarks/#proc-JBoss_Portal_as_the_Identity_Provider_IDP_and_Salesforce_as_the_Service_Provider_SP

2. Observe results


Actual results:

Process blocks don't have the next previous navigation automatically inserted.


Expected results:

Process blocks are rendered as they were before.
Comment 1 Lee Newson 2013-09-11 21:21:22 EDT
Fixed in 1.0.2.

The problem was caused by the way processes were transformed from the new format. The transformer was only picking up processes and applying the relationships if the process was at the base level, and as such any that were a child of a level wouldn't have any relationships applied.
Comment 2 Lee Newson 2013-09-11 21:21:56 EDT
From IRC:

<jmorgan> Verified, lnewson.

Note You need to log in before you can comment on or make changes to this bug.