Bug 1007143 - cups-pdf should log location of each output PDF generated
cups-pdf should log location of each output PDF generated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 22:22 EDT by Dale R. Worley
Modified: 2013-09-22 20:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: cups-pdf-2.6.1-6.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-21 04:28:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale R. Worley 2013-09-11 22:22:35 EDT
Description of problem:

There are a considerable number of complaints logged on various forums, "Where does cups-pdf put my pdf file?"  The immediate needs of users could be served by modifying the message in /var/log/cups/cups-pdf_log to show the output file.  Currently the message reads

Wed Sep 11 21:39:57 2013  [STATUS] PDF creation successfully finished (worley)

If the output file name were added, it would read something like this:

Wed Sep 11 21:39:57 2013  [STATUS] PDF creation successfully finished (worley): /home/worley/Desktop/1234.pdf

Thus, if a user was frantically trying to figure out where his PDF went (because he has a presentation to give in 30 minutes), the sysadmin could look in cups-pdf_log to find out.  This is not a systematic solution to the problem, but it makes the obvious line of attack (look at the cups-pdf log file!) quickly effective.

Also, the comments in /etc/cups/cups-pdf.conf say:

##     ${DESKTOP} will be expanded to the user's desktop directory

This is thoroughly unclear, because what is "the user's desktop directory"?  A more useful comment would be

##     ${DESKTOP} will be expanded to the user's desktop directory, which is ${HOME}/Desktop

or whatever the intended value is.


Version-Release number of selected component (if applicable):

cups-pdf-2.6.1-4.fc19.x86_64


How reproducible:

Examine /var/log/cups/cups-pdf_log after sending any print job to the cups-pdf printer.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Remi Collet 2013-09-12 07:58:40 EDT
(In reply to Dale R. Worley from comment #0)
> Wed Sep 11 21:39:57 2013  [STATUS] PDF creation successfully finished
> (worley)
> 
> If the output file name were added, it would read something like this:
> 
> Wed Sep 11 21:39:57 2013  [STATUS] PDF creation successfully finished
> (worley): /home/worley/Desktop/1234.pdf

Seems a good idea.

> Also, the comments in /etc/cups/cups-pdf.conf say:
> 
> ##     ${DESKTOP} will be expanded to the user's desktop directory

We cannot explicitly tell what is this folder, which is locale dependent, 

Comments also says
##  Add for Fedora (see ~/.config/user-dirs.dirs)

so the user have to read ~/.config/user-dirs.dirs
(or understand what "Desktop folder" means).
Comment 2 Fedora Update System 2013-09-12 08:07:10 EDT
cups-pdf-2.6.1-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cups-pdf-2.6.1-6.fc19
Comment 3 Fedora Update System 2013-09-12 08:07:23 EDT
cups-pdf-2.6.1-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cups-pdf-2.6.1-6.fc20
Comment 4 Dale R. Worley 2013-09-12 09:25:42 EDT
Edited the summary line to change "should lot" to "should log".
Comment 5 Dale R. Worley 2013-09-12 09:31:20 EDT
(In reply to Remi Collet from comment #1)
> > Also, the comments in /etc/cups/cups-pdf.conf say:
> > 
> > ##     ${DESKTOP} will be expanded to the user's desktop directory
> 
> We cannot explicitly tell what is this folder, which is locale dependent, 
> 
> Comments also says
> ##  Add for Fedora (see ~/.config/user-dirs.dirs)
> 
> so the user have to read ~/.config/user-dirs.dirs
> (or understand what "Desktop folder" means).

Looking at ny ~/.config/user-dirs.dirs, I see:

# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
# 
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

Is the desktop directory the value of XDG_DESKTOP_DIR?  If so, perhaps these comments:

##  Add for Fedora (~/.config/user-dirs.dirs)
##     ${DESKTOP} will be expanded to the user's desktop directory

could be improved to:

##  And for Fedora:
##     ${DESKTOP} will be expanded to the user's desktop directory
##     (as defined by XDG_DESKTOP_DIR in ~/.config/user-dirs.dirs)
Comment 6 Fedora Update System 2013-09-12 12:32:05 EDT
Package cups-pdf-2.6.1-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-pdf-2.6.1-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16566/cups-pdf-2.6.1-6.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-09-21 04:28:10 EDT
cups-pdf-2.6.1-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-09-22 20:14:12 EDT
cups-pdf-2.6.1-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.