Bug 1007156 - "Execute failed:unauthorized" shows when login rockmongo from browser
"Execute failed:unauthorized" shows when login rockmongo from browser
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 23:14 EDT by Lei Zhang
Modified: 2015-05-14 19:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 10:32:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rockmongo can't be accessed (34.92 KB, image/png)
2013-09-11 23:29 EDT, Lei Zhang
no flags Details

  None (edit)
Description Lei Zhang 2013-09-11 23:14:25 EDT
Description of problem:
Given a normal app embedded with mongodb and rockmongo created(e.g.,myjbossas7), login rockmongo from browser, found 'Execute failed:unauthorized' shows in web page

Version-Release number of selected component (if applicable):
INT(devenv-3775)

How reproducible:
always

Steps to Reproduce:
1. rhc app create myjbossas7 jbossas-7 mongodb-2.2 rockmongo-1.1
2. Access URL https://myjbossas7-chunchen.dev.rhcloud.com/rockmongo/  and input username, password, and dbname to login rockmongo
3.

Actual results:
"Execute failed:unauthorized" shows in rockmongo web page


Expected results:
rockmongo should be accessed successfully.


Additional info:
Comment 1 Lei Zhang 2013-09-11 23:29:28 EDT
Created attachment 796607 [details]
rockmongo can't be accessed
Comment 2 Dan Mace 2013-09-12 10:32:30 EDT
The "DB Name(s)" field in the Rockmongo login page is only for use when specifying a non-admin user. Using it with the admin user will produce the error you're seeing.

If you omit the "DB Name(s)" field (or create a non-admin user to specify), you'll be able to log in.

I don't think it's a very intuitive UI (the DB name field appears under a "Non-Admin users:" header with no explanation), but it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.