Bug 1007176 - Add VPC and VHDX file formats as supported in qemu-kvm (read-only)
Add VPC and VHDX file formats as supported in qemu-kvm (read-only)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
: 1006662 (view as bug list)
Depends On:
Blocks: 961854 977441 1006159
  Show dependency treegraph
 
Reported: 2013-09-12 00:48 EDT by Sibiao Luo
Modified: 2014-06-17 23:36 EDT (History)
10 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-15.el7
Doc Type: Release Note
Doc Text:
VPC and VHDX File Formats KVM in Red Hat Enterprise Linux 7.0 Beta includes support for the Microsoft Virtual PC (VPC) and Microsoft Hyper-V virtual hard disk (VHDX) file formats.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:02:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-09-12 00:48:58 EDT
Description of problem:
fail to boot guest with vpc file format disk in qemu-kvm. we has fixed this issue in rhel6.5(bug 999779), so we need to backport the code to rhel7 also.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
3.10.0-18.el7.x86_64
qemu-kvm-1.5.3-2.el7.x86_64
guest info:
3.10.0-18.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create a vpc file format disk.
# qemu-img create -f vpc sluo-data-disk.vpc 10G
Formatting 'sluo-data-disk.vpc', fmt=vpc size=10737418240 
# qemu-img info sluo-data-disk.vpc
image: sluo-data-disk.vpc
file format: vpc
virtual size: 10G (10737893376 bytes)
disk size: 24K
2.boot guest with vpc format file in KVM.
e.g:...-drive file=/home/sluo-data-disk.vpc,if=none,format=vpc,id=drive-data-disk,werror=stop,rerror=stop,*readonly=on* -device virtio-scsi-pci,bus=pci.0,addr=0x7,id=scsi0 -device scsi-hd,drive=drive-data-disk,id=data-disk,bus=scsi0.0

Actual results:
after step 2, qemu will quit with prompt that 'vpc' invalid format, like:
Warning: option deprecated, use lost_tick_policy property of kvm-pit instead.
qemu-kvm: -drive file=/home/sluo-data-disk.vpc,if=none,format=vpc,id=drive-data-disk,werror=stop,rerror=stop,readonly=on: 'vpc' invalid format
/etc/qemu-ifdown: could not launch network script

Expected results:
Qemu should support the vpc file format.

Additional info:
# /usr/libexec/qemu-kvm -drive format=?
Supported formats: vvfat vpc vmdk vhdx vdi sheepdog sheepdog sheepdog raw host_cdrom host_floppy host_device file qed qcow2 qcow parallels nbd nbd nbd iscsi gluster gluster gluster gluster dmg cow cloop bochs blkverify blkdebug
Comment 1 Jeff Cody 2013-09-13 15:25:57 EDT
vpc needs to be added to the rpm spec template drive r/o whitelist
Comment 2 Ademar Reis 2013-11-05 14:41:35 EST
(In reply to Jeff Cody from comment #1)
> vpc needs to be added to the rpm spec template drive r/o whitelist

And so does VHDX (until read/write support is added)
Comment 3 Jeff Cody 2013-11-06 10:33:58 EST
*** Bug 879234 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Cody 2013-11-06 14:41:41 EST
*** Bug 1006662 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Rezanina 2013-11-07 03:26:23 EST
Fix included in qemu-kvm-1.5.3-15.el7
Comment 7 Sibiao Luo 2013-11-17 22:34:37 EST
Verify this issue on qemu-kvm-1.5.3-19.el7.x86_64 that with VPC and VHDX format disk, it can boot up with vpc/vhdx format disk specified readonly=on, so this issue has been fixed correctly.

host info:
# uname -r && rpm -q qemu-kvm
3.10.0-41.el7.x86_64
qemu-kvm-1.5.3-19.el7.x86_64

Best regards,
sluo
Comment 8 Ludek Smid 2014-06-13 06:02:41 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.