Bug 1007193 - RHEV-H 6.5 register to RHEV-M 3.3 failed, registerVDS status: 404 reason: Not Found.
RHEV-H 6.5 register to RHEV-M 3.3 failed, registerVDS status: 404 reason: Not...
Status: CLOSED DUPLICATE of bug 982202
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Alon Bar-Lev
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 01:37 EDT by Ying Cui
Modified: 2016-02-10 14:00 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 02:40:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm-reg.log (19.49 KB, text/plain)
2013-09-12 01:37 EDT, Ying Cui
no flags Details

  None (edit)
Description Ying Cui 2013-09-12 01:37:05 EDT
Description of problem:
RHEV-H 6.5 register to RHEV-M 3.3 failed, registerVDS status: 404 reason: Not Found.

Version-Release number of selected component (if applicable):
RHEV-M  3.3.0-0.14.master.el6ev
rhev-hypervisor6-6.5-20130910.2.el6ev.noarch.rpm
vdsm-reg-4.12.0-127.gitedb88bf.el6ev.noarch
vdsm-4.12.0-127.gitedb88bf.el6ev.x86_64
ovirt-node-plugin-vdsm-0.1.1-7.el6ev.noarch
ovirt-node-3.0.0-6.1.el6.noarch

How reproducible:
100%
 
Steps to Reproduce:
1. Clean install rhev-hypervisor6-6.5-20130910.2.el6ev successful.
2. Configure network with IPv4 address successful.
3. oVirt-engine configure in RHEV-H TUI.
4. Retrieve Certificate
5. Click on '< Save & Register >' to register RHEV-M 3.3.

Actual result:
1. Access RHEV-M 3.3 web administrator portal, Hosts tab, there is no host record display in here.
2. Checked vdsm-reg.log in RHEV-H, there display register false.

<snip>
...
MainThread:EBUG::2013-09-11 10:02:34,735::vdsm-reg-setup::124::root::registerVDS URI= /RHEVManagerWeb/VdsAutoRegistration.aspx?vds_ip=10.66.86.26&__VIEWSTATE=&vds_unique_id=AD15E221-EC68-11DE-B43B-000BAB01BFD6&vds_name=intel-s3e36-01.rhts.eng.nay.redhat.com&ticket=&port=54321

MainThread:EBUG::2013-09-11 10:02:34,762::vdsm-reg-setup::155::root::registerVDS status: 404 reason: Not Found
MainThread:EBUG::2013-09-11 10:02:34,763::vdsm-reg-setup::174::root::registerVDS end.
MainThread:EBUG::2013-09-11 10:02:34,763::vdsm-reg-setup::201::root::execute: after registerVDS: False
MainThread:EBUG::2013-09-11 10:02:34,763::vdsm-reg-setup::206::root::Registration status: False
</snip>

Expect result:
1. RHEV-H 6.5 can register to RHEV-M 3.3 successful without error.

Additional info:
When adding Node through oVirt Engine UI, it is successful for adding new Host in web administrator portal.
Comment 1 Ying Cui 2013-09-12 01:37:36 EDT
Created attachment 796624 [details]
vdsm-reg.log
Comment 2 Alon Bar-Lev 2013-09-12 02:25:24 EDT
dup of bug#982202?
Comment 5 Alon Bar-Lev 2013-09-12 02:40:41 EDT
Please report bugs for pre-release only when trying the latest.

Reported: RHEV-M  3.3.0-0.14.master.el6ev
Latest:   RHEV-M  3.3.0-0.21.master.el6ev

*** This bug has been marked as a duplicate of bug 982202 ***
Comment 6 Ying Cui 2013-09-12 05:05:08 EDT
Tested on build RHEV-M  3.3.0-0.21.master.el6ev, do not encounter this bug 404 false on latest RHEV-M.

After registering rhevh 6.5 to rhevm3.3 IS14, the host can be list in Hosts Tab in web administrator portal.

Note You need to log in before you can comment on or make changes to this bug.