Bug 1007198 - Wrong options shown when setting writer tag
Wrong options shown when setting writer tag
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.2
Assigned To: Lee Newson
mmurray
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 01:49 EDT by mmurray
Modified: 2013-10-17 19:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 19:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Assigned writer option starts with Cyberdine but this should not be an option for JBDS (23.49 KB, image/png)
2013-09-12 01:49 EDT, mmurray
no flags Details

  None (edit)
Description mmurray 2013-09-12 01:49:15 EDT
Created attachment 796626 [details]
Assigned writer option starts with Cyberdine but this should not be an option for JBDS

Description of problem:
Sometime default/common options are shown for tag field values rather then project/product values.


Version-Release number of selected component (if applicable):
Build 201309081012


How reproducible: 100%


Steps to Reproduce:
1. Within web-UI view a content spec (e.g., JBDS getting started guide)
2. Click 'tags' > initially fields options set to common, assigned writer, cyerdine
3. Change common to JBDS > final field displays mmurray (all good)
4. Change assigned writer to book > final field displays Internet relay ... (all good)
5. Change book back to assigned writer > final field displays Cyberdine, so the common assigned writer options, not the JBDS assigned writer options (not good)
Comment 1 Lee Newson 2013-09-12 01:59:27 EDT
Verified, this is also a bug in the Topic editor.
Comment 2 Lee Newson 2013-09-12 21:19:17 EDT
Fixed in Build 201309131105.

The problem was caused by the way ValueListBoxes have to be set and a problem with the equals method. For whatever strange reason you need to set the selected value before assigning the list of possible values. As such when the list is loaded the category is set to "Assigned Writer", however at this stage because the old equals method would set the new category as the same as the old one the tags would reference the old list of tags and not the new one.

As such I've fixed the equals method so that it will correctly set the right category/project, as well as a few other minor things that had been done to try and work with the above situation.

Note: This version is currently live on the PressGang Next instance.
Comment 3 mmurray 2013-09-12 21:29:03 EDT
Fix verified: Build 201309131104
Comment 4 Lee Newson 2013-09-12 21:32:16 EDT
Thanks Michelle, and yeah I typed the wrong build number sorry. It should have been 201309131104.

Note You need to log in before you can comment on or make changes to this bug.