Bug 1007231 - RHEVM-JAVA-SDK: session_timeout parameter doesn't exists in API constructor signature
RHEVM-JAVA-SDK: session_timeout parameter doesn't exists in API constructor s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk-java (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Juan Hernández
Ilia Meerovich
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 03:35 EDT by Ilia Meerovich
Modified: 2016-07-04 20:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:18:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19257 None None None Never

  None (edit)
Description Ilia Meerovich 2013-09-12 03:35:08 EDT
There is no support anymore for endless auth.
And ther is no support for session_timeout in rhevm java sdk.
Since there is no support anymore for endless auth, session_timeout starts to be mandatory option (Default timeout is 5 minutes).
Also it is potential automation blocker
Comment 1 Ilia Meerovich 2013-10-10 06:45:39 EDT
verified with is16
Comment 3 Itamar Heim 2014-01-21 17:18:48 EST
Closing - RHEV 3.3 Released
Comment 4 Itamar Heim 2014-01-21 17:25:06 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.