Bug 1007235 - Filters/Weights/Balancers are disabled instead of removed in webadmin, when python script is removed.
Filters/Weights/Balancers are disabled instead of removed in webadmin, when p...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: nobody nobody
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 03:44 EDT by Ondra Machacek
Modified: 2016-02-10 15:17 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 09:55:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2013-09-12 03:44:11 EDT
Description of problem:
When python script with filter/weight/balancer is removed from direcotory
for those scripts, then in webadmin it is still visible as disabled.

Version-Release number of selected component (if applicable):
is12

How reproducible:
always

Steps to Reproduce:
1. Create some easy filter and add it to /usr/share/ovirt-scheduler-proxy/plugins/
2. enable external filters rhevm-config -s ExternalSchedulerEnabled=true
3. service ovirt-scheduler-proxy start
4. service ovirt-engine restart
5. Now in webadmin we can use this filter.
6. Remove that script from /usr/share/ovirt-scheduler-proxy/plugins/
7. service ovirt-scheduler-proxy restart
8. service ovirt-engine restart
9. Try to create new cluster policy (configure->cluster policies)

Actual results:
We can still see removed external filter.

Expected results:
We cannot see external filter, which don't longer exists.

Additional info:
Comment 1 Doron Fediuck 2013-09-16 09:55:42 EDT
Ondra this is by design.
Removal of elements should be done manually, since it may effect several
policies. So there is a way to manually remove the disabled policy elements,
once you verified it is indeed no longer needed and/or being used.

Note You need to log in before you can comment on or make changes to this bug.