Bug 1007259 - SELinux is preventing /usr/sbin/ifconfig from 'search' accesses on the directory net.
SELinux is preventing /usr/sbin/ifconfig from 'search' accesses on the direct...
Status: CLOSED DUPLICATE of bug 1007257
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:527ebd694f208c204ad97303e46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 04:12 EDT by Sven Kieske
Modified: 2013-09-12 05:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 05:24:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Kieske 2013-09-12 04:12:59 EDT
Description of problem:
SELinux is preventing /usr/sbin/ifconfig from 'search' accesses on the directory net.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es ifconfig standardmässig erlaubt sein sollte, search Zugriff auf net directory zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep ifconfig /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:passenger_t:s0
Target Context                system_u:object_r:sysctl_net_t:s0
Target Objects                net [ dir ]
Source                        ifconfig
Source Path                   /usr/sbin/ifconfig
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           net-tools-2.0-0.6.20130109git.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-73.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.10-200.fc19.x86_64 #1 SMP Thu
                              Aug 29 19:05:45 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-09-04 16:31:41 CEST
Last Seen                     2013-09-08 04:01:07 CEST
Local ID                      a5ebc280-a0ba-4bcb-a3e1-d64b6c662139

Raw Audit Messages
type=AVC msg=audit(1378605667.575:9197): avc:  denied  { search } for  pid=19717 comm="ifconfig" name="net" dev="proc" ino=278853 scontext=system_u:system_r:passenger_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir


type=SYSCALL msg=audit(1378605667.575:9197): arch=x86_64 syscall=access success=no exit=ENOENT a0=7f4a5d03a808 a1=4 a2=0 a3=a items=0 ppid=19716 pid=19717 auid=4294967295 uid=52 gid=52 euid=52 suid=52 fsuid=52 egid=52 sgid=52 fsgid=52 ses=4294967295 tty=(none) comm=ifconfig exe=/usr/sbin/ifconfig subj=system_u:system_r:passenger_t:s0 key=(null)

Hash: ifconfig,passenger_t,sysctl_net_t,dir,search

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.10-200.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-09-12 05:24:33 EDT

*** This bug has been marked as a duplicate of bug 1007257 ***

Note You need to log in before you can comment on or make changes to this bug.