Bug 1007290 - Missing 'save' button under content-view filters --> 'Repositories' tab
Missing 'save' button under content-view filters --> 'Repositories' tab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: David Davis
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 04:54 EDT by Sachin Ghai
Modified: 2014-04-24 13:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:07:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
missing save button under content-view filters --> 'Repositories' tab (38.30 KB, image/png)
2013-09-12 04:54 EDT, Sachin Ghai
no flags Details
green check-mark 'Saved' appears as success (68.33 KB, image/png)
2013-10-21 06:29 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-09-12 04:54:01 EDT
Created attachment 796694 [details]
missing save button under content-view filters --> 'Repositories' tab

Description of problem:
The 'save' button is missing under 'Repositories' tab of content-view filters.
I think its because of new addition of Puppet Repository' panel.

Version-Release number of selected component (if applicable):
katello-1.4.6-1.git.95.3ef5eb8.el6.noarch

How reproducible:
always 

Steps to Reproduce:
1. Create a content-view 
2. create a filter
3. Go to repositories tab

Actual results:
Missing Save button

Expected results:
Save button should be there.

Additional info:
Comment 3 Og Maciel 2013-09-12 08:44:19 EDT
Sachin, I saw that yesterday and it seems that it the change was done on purpose. As you mentioned before, your selection persists as you switch between tabs. Need to verify with DEV and if this is the design, then we need to update our code.
Comment 4 Sachin Ghai 2013-09-13 03:49:05 EDT
In case the change is as per design then UI should raise a notification on selecting a product or repo.
Comment 5 Brad Buckingham 2013-09-13 09:23:41 EDT
This is a change that was introduced by https://github.com/Katello/katello/pull/2870 .  Rather than require the user to click 'save' the product/repo selector was updated to use ajax to perform an immediate update.
Comment 6 David Davis 2013-09-13 09:48:52 EDT
Regarding notifications. Currently we are showing a spinner that disappears when the product/repo is saved. We also log a notification to the database but we don't show it to the user. 

I tried turning on notifications but it looks like there is some type of bug (Justin confirmed this) where the code checks the notification type and clears out notifications of the same type. I think this was to reduce dupe errors. The problem is that it only shows one notice if you update the definition 2+ times in quick succession. 

I could fix this but then the user would probably be bombarded with notices depending on how fast they update the definition. Also, I'm not sure what sort of regressions I might introduce.

Another alternative would be maybe to show some sort of indicator on the page that the definition was updated (as opposed to a notice). The downside to this would be that it would be inconsistent with the rest of the app and it'll be temporary as the page will be redone soon with the nutupane changes.

Does anyone have any ideas or preferences?
Comment 7 David Davis 2013-09-13 09:51:20 EDT
Another option would be to go back to a single save button and just show a notice once it's clicked?
Comment 8 Sachin Ghai 2013-09-16 05:17:02 EDT
I need the notification so as to ensure(while automating test) whether the repo/product is properly selected.
Comment 9 RHEL Product and Program Management 2013-09-17 00:14:04 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 11 David Davis 2013-09-17 10:11:46 EDT
https://github.com/Katello/katello/pull/2966
Comment 12 David Davis 2013-09-17 10:19:33 EDT
Suchin, I tried to contact you on IRC to test out the success notification stuff. You should now see a green check mark if the definition gets updated successfully. It'll disappear after 3 seconds or if there's activity. Please test it out (once it gets merged) and let me know if you have any feedback.
Comment 14 David Davis 2013-09-17 12:56:51 EDT
Katello commit:

6fc8d4a2756d47dee94c83718462ea3249046d17
Comment 16 Sachin Ghai 2013-10-21 06:27:45 EDT
Verified with snap6 compose2 (MDP2)

katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch


We have now + Add button to select the repositories. When user select it and click on 'Add' , a green check mark appears which disappears after few secs (as mentioned in comment13)
Comment 17 Sachin Ghai 2013-10-21 06:29:40 EDT
Created attachment 814523 [details]
green check-mark 'Saved' appears as success
Comment 18 Bryan Kearney 2014-04-24 13:07:53 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.