Bug 1007300 - Installation on AWS (CentOS) fails
Installation on AWS (CentOS) fails
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: graphite-web (Show other bugs)
el6
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jonathan Steffan
Fedora Extras Quality Assurance
:
: 1007316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 05:05 EDT by Daniel Scott
Modified: 2013-10-18 15:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: graphite-web-0.9.12-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 02:26:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch which creates installable patch for AWS Linux (511 bytes, patch)
2013-09-12 05:05 EDT, Daniel Scott
no flags Details | Diff

  None (edit)
Description Daniel Scott 2013-09-12 05:05:36 EDT
Created attachment 796709 [details]
Spec file patch which creates installable patch for AWS Linux

Description of problem:
Installation on AWS (CentOS) fails with:

Package python-sqlite2 is obsoleted by python24-sqlite, but obsoleting package does not provide for requirements
Error: Package: graphite-web-0.9.10-7.el6.noarch (epel)
           Requires: python-sqlite2
           Available: 1:python-sqlite2-2.3.5-2.el6.x86_64 (epel)
               python-sqlite2 = 1:2.3.5-2.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


So, it appears that the AWS repos attempt to install python24-sqlite because it apparently provides python-sqlite2. However, I believe that this dependency is not actually required for modern Python (2.6/2.7).

I see that the spec file contains a conditional for Fedora Versions >17 which removes the requirement. Can the file be modified to remove this requirement for CentOS/AWS Linux too?

Also, the python-django package does not exist on CentOS or AWS Linux, I believe that it's called Django14.

Patch attached, which allows me to create an installable RPM for AWS Linux. However, it will likely break Fedora.
Comment 1 Jonathan Steffan 2013-09-19 19:26:10 EDT
Thanks for the report. I will work on getting this installable on AWS Linux without breaking the current targets. What AMI are you using so I can do some testing also?
Comment 2 Jonathan Steffan 2013-09-19 19:28:10 EDT
*** Bug 1007316 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Scott 2013-09-20 01:36:08 EDT
Hi,

It's the standard Amazon Linux AMI 2013.03.1 (64bit) - ami-c7c0d6b3.

The problem still exists in the latest version (0.9.12 - released yesterday) the same patch (above) still works.

Thanks,

Dan
Comment 4 Jonathan Steffan 2013-09-24 20:32:48 EDT
I did a quick test against ami-05355a6c and 0.9.12-3.el6 should fix the issue you are running into.
Comment 5 Fedora Update System 2013-09-24 20:34:37 EDT
graphite-web-0.9.12-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/graphite-web-0.9.12-3.fc19
Comment 6 Fedora Update System 2013-09-24 20:34:55 EDT
graphite-web-0.9.12-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/graphite-web-0.9.12-3.fc20
Comment 7 Fedora Update System 2013-09-24 20:35:08 EDT
graphite-web-0.9.12-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/graphite-web-0.9.12-3.fc18
Comment 8 Fedora Update System 2013-09-24 20:35:21 EDT
graphite-web-0.9.12-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/graphite-web-0.9.12-3.el6
Comment 9 Fedora Update System 2013-09-25 13:18:09 EDT
Package graphite-web-0.9.12-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing graphite-web-0.9.12-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11684/graphite-web-0.9.12-3.el6
then log in and leave karma (feedback).
Comment 10 Daniel Scott 2013-09-26 03:44:34 EDT
Working fine now. Thanks!
Comment 11 Fedora Update System 2013-10-02 02:26:43 EDT
graphite-web-0.9.12-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-10-17 14:02:22 EDT
graphite-web-0.9.12-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-10-18 15:40:08 EDT
graphite-web-0.9.12-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-10-18 15:43:19 EDT
graphite-web-0.9.12-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.