Bug 1007306 - No box pop out when input a wrong password and retry connection for vnc guest
No box pop out when input a wrong password and retry connection for vnc guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jonathon Jongsma
Virtualization Bugs
:
Depends On: 1007295
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 05:08 EDT by tingting zheng
Modified: 2015-03-05 08:38 EST (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
When connecting to a password-protected VNC guest, if the wrong password was entered, the user was notified of the error, but was not presented with another password prompt to try again. With this fix, the password prompt will be displayed again if the user enters an incorrect password.
Story Points: ---
Clone Of: 1007295
Environment:
Last Closed: 2015-03-05 08:38:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2013-09-12 05:08:26 EDT
The bug can also be reproduced on rhel7,so cloned the bug.

+++ This bug was initially created as a clone of Bug #1007295 +++

Description
No box pop out when input a wrong password and retry connection for vnc guest

Version:
virt-viewer-0.5.6-7.el6.x86_64
libvirt-0.10.2-24.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a vnc guest with password.
2. Use remote-viewer vnc://$ip:$port to connect the guest.
3. Input a wrong password for the guest.
4. Messages show "Unable to authenticate with remote desktop server at vnc://localhost:5900: Authentication failed Retry connection again?"
5. Click "yes",no box pop out for input password again.

Actual results:
As description.

Expected results:
Box pop out for input password again.

Additional info:
1.If use virt-viewer $vncguest,no such issue.
2.The issue doesn't exist with spice guest.
3.Attached virt-viewer debug info.
Comment 5 tingting zheng 2014-07-22 02:04:57 EDT
I can reproduce this bug with:
virt-viewer-0.5.7-7.el7.x86_64

Tested pass with:
virt-viewer-0.6.0-1.el7.x86_64

Steps:
1. Prepare a vnc guest with password.
2. Use remote-viewer vnc://$ip:$port to connect the guest.
3. Input a wrong password for the guest.
4. Messages show "Unable to authenticate with remote desktop server at vnc://localhost:5900: Authentication failed Retry connection again?"
5. Click "yes",a new authentication box pop out.
6. After input the correct password,guest can be launched successfully.

Refer to the above comments,move the bug to VERIFIED.
Comment 7 errata-xmlrpc 2015-03-05 08:38:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.