This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1007369 - Missing requirement on dblatex
Missing requirement on dblatex
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: asciidoc (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 06:52 EDT by Fabian Deutsch
Modified: 2013-09-12 10:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 07:45:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-09-12 06:52:01 EDT
Description of problem:
a2x -f pdf requires dblatex. Please add a Requirement on this package.
Comment 1 Stanislav Ochotnicky 2013-09-12 07:45:57 EDT
This was omitted intentionally[1] because not all asciidoc usecases require pdf support (such as html/manpage generation) and dblatex dependency chain is quite huge. What could possibly be done is a fedora-specific patch for a2x that would print some sane error message prompting to install dblatex (or rather latex subpackage). There is asciidoc-latex subpackage that pulls in dblatex and includes additional settings.


[1] https://lists.fedoraproject.org/pipermail/devel/2013-March/179571.html
Comment 2 Fabian Deutsch 2013-09-12 10:01:41 EDT
Thanks for the info.

The patch is probably a good thing tho power-users might know what to do ..

Note You need to log in before you can comment on or make changes to this bug.