Bug 1007371 - Incompatibility with saxon 9.3.0.4
Incompatibility with saxon 9.3.0.4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xml-maven-plugin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Nalley
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 06:56 EDT by Marek Goldmann
Modified: 2013-09-13 05:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 05:12:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Goldmann 2013-09-12 06:56:28 EDT
Description of problem:

The current version of xml-maven-plugin is 1.0 and it requires saxon in version 8.7 by upstream. In Fedora Rawhide we have version 9.3.0.4.

When trying to build new HornetQ (2.4.0.Beta1) it fails at this line:

https://github.com/hornetq/hornetq/blob/HornetQ_2_4_0_Beta1/hornetq-core-client/src/main/resources/hqDefaults.xsl#L20

Build log: https://gist.github.com/goldmann/6534492

When I replaced Fedora's saxon.jar with upstream version 8.7 I could compile HornetQ without any issues.

If there will a fixed version - I'm happy to test it.

Version-Release number of selected component (if applicable):

saxon-9.3.0.4-8.fc20.noarch
Comment 1 Marek Goldmann 2013-09-13 05:12:48 EDT
It seems this is not a bug, the hornetq pom file was missing the <transformerFactory/> element in configuration for the xml-maven-plugin:

        <configuration>
          <transformerFactory>net.sf.saxon.TransformerFactoryImpl</transformerFactory>
          <transformationSets>
            <transformationSet>
              <dir>xml</dir>
              <stylesheet>it8.xsl</stylesheet>
            </transformationSet>
          </transformationSets>
        </configuration>

Closing.

Note You need to log in before you can comment on or make changes to this bug.