Bug 1007381 - proxy provider: id lookup shows "Memory buffer error" in domain log
proxy provider: id lookup shows "Memory buffer error" in domain log
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On: 895565
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2013-09-12 07:35 EDT by Stephen Beal
Modified: 2014-10-14 00:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: sssd-1.11.5.1-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: The proxy provider's group handling had a bug where the provider expected every user has at least one supplemetary group. Consequence: If a user who belongs to his private group only was requested, the request finished with an error. Fix: The proxy provider was fixed to handle users with no supplemetary groups fine. Result: Requesting users with no supplementary groups works now.
Story Points: ---
Clone Of: 895565
Environment:
Last Closed: 2014-10-14 00:46:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 484823 None None None Never
Red Hat Product Errata RHBA-2014:1375 normal SHIPPED_LIVE sssd bug fix and enhancement update 2014-10-13 21:06:25 EDT

  None (edit)
Comment 2 Jakub Hrozek 2013-09-12 08:04:09 EDT
To test, configure a proxy provider that proxies to files and request a user that is only a member of his private group, not any supplementary group.
Comment 5 Jakub Hrozek 2013-09-19 04:34:41 EDT
This bug is targeting 6.6
Comment 6 Jakub Hrozek 2013-10-17 04:56:44 EDT
There is an upstream patch, moving to ASSIGNED
Comment 7 Jakub Hrozek 2013-10-31 07:21:28 EDT
Fixed upstream in 66d1f565dfb39325ab7daa264b5795b1f348756e
Comment 10 Kaushik Banerjee 2014-07-14 12:00:11 EDT
Verified with sssd version 1.11.6-1.el6

Output from beaker automation run:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: proxy_rfc2307_06: BZ1007381 initgroup returns memory buffer error
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

uid=1111111(User_CS1_Alias) gid=1111111(User_CS1_grp1_Alias) groups=1111111(User_CS1_grp1_Alias)
:: [   PASS   ] :: Running 'id User_CS1' (Expected 0, got 0)
:: [   PASS   ] :: File '/var/log/sssd/sssd_PROXY.log' should contain 'Assume the user is only member of its primary group' 
:: [   PASS   ] :: File '/var/log/sssd/sssd_PROXY.log' should not contain 'Memory buffer' 
proxy-rfc2307-06 result: PASS
Comment 11 errata-xmlrpc 2014-10-14 00:46:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1375.html

Note You need to log in before you can comment on or make changes to this bug.