Bug 1007385 - Calendars don't work, when we work with two KieContainers
Calendars don't work, when we work with two KieContainers
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Mario Fusco
Tomas David
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 07:36 EDT by Tomas David
Modified: 2014-08-06 16:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DROOLS-260 Major Resolved Drools not writing calendars when marshalling 2017-09-13 09:37 EDT

  None (edit)
Description Tomas David 2013-09-12 07:36:50 EDT
Description of problem:
Calendars don't work, when new KieContainer is created and newKieSession is called right after creation of other KieContainer and calling getKieBase. 

Version-Release number of selected component (if applicable):
Drools 6.0.0-SNAPSHOT
6.0.0.ER2

How reproducible:
Pull request #251 submited in Drools.

Steps to Reproduce:
1. Make drl file with two rules. First rule should fire only on weekdays. Second rule should fire only on weekend days. 
2. Write a test with this order of commands:
 - create first KieContainer and call getKieBase()
 - create second KieContainer
 - from second KieContainer create new session ( newKieSession() )
 - add calendars to session and call fireAllRules()
3. Run test.

Actual results:
Two rules are fired.

Expected results:
Only one rule should fired.

Additional info:
Comment 2 Mario Fusco 2013-10-04 13:00:50 EDT
I couldn't reproduce this issue on the master. Very likely it was related by this issue:

https://issues.jboss.org/browse/DROOLS-260

that has been fixed with this commit:

https://github.com/droolsjbpm/drools/commit/39276fea9209353bf3704663da0b03ef934cc908
Comment 6 Tomas David 2013-11-29 11:01:58 EST
Verified on BRMS 6.0.0.ER5.

Note You need to log in before you can comment on or make changes to this bug.