Bug 1007387 - ValueError: ('invalid size specification', '1.52587892899e-06 mb')
Summary: ValueError: ('invalid size specification', '1.52587892899e-06 mb')
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:89f61842eba639be425e2a2519b...
Depends On:
Blocks: F20AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2013-09-12 11:40 UTC by Lukas Brabec
Modified: 2013-09-19 02:38 UTC (History)
13 users (show)

Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-19 02:38:26 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (658.55 KB, text/plain)
2013-09-12 11:40 UTC, Lukas Brabec
no flags Details
File: anaconda.log (7.84 KB, text/plain)
2013-09-12 11:40 UTC, Lukas Brabec
no flags Details
File: environ (441 bytes, text/plain)
2013-09-12 11:40 UTC, Lukas Brabec
no flags Details
File: lsblk_output (1.30 KB, text/plain)
2013-09-12 11:40 UTC, Lukas Brabec
no flags Details
File: nmcli_dev_list (4.35 KB, text/plain)
2013-09-12 11:40 UTC, Lukas Brabec
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-12 11:41 UTC, Lukas Brabec
no flags Details
File: program.log (28.00 KB, text/plain)
2013-09-12 11:41 UTC, Lukas Brabec
no flags Details
File: storage.log (68.26 KB, text/plain)
2013-09-12 11:41 UTC, Lukas Brabec
no flags Details
File: syslog (64.70 KB, text/plain)
2013-09-12 11:41 UTC, Lukas Brabec
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-09-12 11:41 UTC, Lukas Brabec
no flags Details
File: packaging.log (443.50 KB, text/plain)
2013-09-12 11:41 UTC, Lukas Brabec
no flags Details

Description Lukas Brabec 2013-09-12 11:40:21 UTC
Description of problem:
Tried to select partition to delete when installing F20 Alpha RC2 netinst.

Version-Release number of selected component:
anaconda-20.15-1

The following was filed automatically by anaconda:
anaconda 20.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/lib/disks.py", line 82, in size_str
    return str(Size(spec=spec)).upper()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 218, in _update_labels
    text = _("Total selected space to reclaim: <b>%s</b>") % size_str(selectedReclaimable)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 454, in on_resize_value_changed
    self._update_labels(selectedReclaimable=self._selectedReclaimableSpace)
ValueError: ('invalid size specification', '1.52587892899e-06 mb')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha

Comment 1 Lukas Brabec 2013-09-12 11:40:31 UTC
Created attachment 796805 [details]
File: anaconda-tb

Comment 2 Lukas Brabec 2013-09-12 11:40:36 UTC
Created attachment 796806 [details]
File: anaconda.log

Comment 3 Lukas Brabec 2013-09-12 11:40:41 UTC
Created attachment 796807 [details]
File: environ

Comment 4 Lukas Brabec 2013-09-12 11:40:47 UTC
Created attachment 796808 [details]
File: lsblk_output

Comment 5 Lukas Brabec 2013-09-12 11:40:55 UTC
Created attachment 796809 [details]
File: nmcli_dev_list

Comment 6 Lukas Brabec 2013-09-12 11:41:00 UTC
Created attachment 796810 [details]
File: os_info

Comment 7 Lukas Brabec 2013-09-12 11:41:04 UTC
Created attachment 796811 [details]
File: program.log

Comment 8 Lukas Brabec 2013-09-12 11:41:09 UTC
Created attachment 796812 [details]
File: storage.log

Comment 9 Lukas Brabec 2013-09-12 11:41:14 UTC
Created attachment 796813 [details]
File: syslog

Comment 10 Lukas Brabec 2013-09-12 11:41:18 UTC
Created attachment 796814 [details]
File: ifcfg.log

Comment 11 Lukas Brabec 2013-09-12 11:41:26 UTC
Created attachment 796815 [details]
File: packaging.log

Comment 12 Lukas Brabec 2013-09-12 11:49:26 UTC
Steps to reproduce:
1. select disc, done
2. reclaim space
3. select first partition (sda1)
4. select the whole disc (sda) back again

Comment 13 Lukas Brabec 2013-09-12 12:01:03 UTC
The installer must be able to complete an installation to a single disk using automatic partitioning. Proposing as blocker bug.

Comment 14 Kamil Páral 2013-09-12 12:07:17 UTC
In a reclaim space dialog I tried to click on all the available partitions and on the disk item. Probably a dupe of bug 1007387.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet inst.repo=http://download.eng.brq.redhat.com/pub/fedora/linux/development/20/x86_64/os/ BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.15-1
product:        Fedora
reason:         ValueError: ('invalid size specification', '1.52587892899e-06 mb')
release:        Cannot get release name.
version:        20-Alpha

Comment 15 Tim Flink 2013-09-12 16:48:55 UTC
I started an install with F20 alpha RC2 x86_64 dvd in a vm. After selecting a disk, and getting into the reclaim space dialog, I clicked on a partition with the intention of deleting it but saw the crash before I could click 'delete'

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.15-1
product:        Fedora
reason:         ValueError: ('invalid size specification', '-3.05175780113e-06 mb')
release:        Cannot get release name.
version:        20-Alpha

Comment 16 David Lehman 2013-09-12 20:20:49 UTC
Updates image for testing against anaconda-20.15:

  http://dlehman.fedorapeople.org/updates/updates-1007387.0.img

Comment 17 Tim Flink 2013-09-13 21:48:35 UTC
tested the updates.img from c#16 with f20 alpha RC2 x86_64 installing to a VM. Able to delete partitions individually with no issues and complete the install.

Comment 18 Lukas Brabec 2013-09-16 08:17:48 UTC
Updates.img (from c#16) solved the problem (F20 Alpha RC2 x86_64 DVD in virtual machine).

Comment 19 Petr Schindler 2013-09-16 15:07:10 UTC
Discussed at 2013-09-12 go/no-go meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion: "The installer must be able to complete an installation to a single disk using automatic partitioning." [2]

[1] http://meetbot.fedoraproject.org/fedora-meeting-2/2013-09-12/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Remote_package_sources

Comment 20 Fedora Update System 2013-09-16 17:46:01 UTC
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20

Comment 21 Kamil Páral 2013-09-17 13:01:48 UTC
I tested with Alpha RC3 and everything seems fine, no crash.

Comment 22 Fedora Update System 2013-09-19 02:38:26 UTC
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.