Bug 1007393 - [scale] The thread pool is out of limit
[scale] The thread pool is out of limit
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.4.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.4.1
Assigned To: Barak
Yuri Obshansky
infra
:
Depends On:
Blocks: 968349
  Show dependency treegraph
 
Reported: 2013-09-12 07:52 EDT by Ayal Baron
Modified: 2016-02-10 14:41 EST (History)
21 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 968349
Environment:
Last Closed: 2014-08-05 04:25:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19744 None None None Never

  None (edit)
Comment 2 Liran Zelkha 2013-10-15 03:33:12 EDT
Please check http://gerrit.ovirt.org/#/c/19744/ for a possible solution.
Roy - the reject policy is run in your own thread, but only after queue is exhausted. I think we should test it under load, but problematic ordering will not be worse than it is today.
Comment 3 Piotr Kliczewski 2013-10-28 06:09:11 EDT
Looking at previous comments there are two solutions:
1. Configurable number of threads and queue size. Solution proposed above.
2. Make IVdsServer implementation async. 

As the first one seems to be ongoing I would like to suggest solution for second one. There is work in progress to have AMQP communication which will introduce async communication. This change can be implemented to provide async behavior for AMQP and http VdsServers.
Comment 5 Sandro Bonazzola 2014-01-14 03:43:39 EST
ovirt 3.4.0 alpha has been released
Comment 8 Yuri Obshansky 2014-06-30 10:58:08 EDT
Bug was verified on RHEVM version 3.4.1-0.23.el6ev
OS Version: RHEL - 6Server - 6.5.0.1.el6
Kernel Version: 2.6.32 - 431.el6.x86_64
KVM Version: 0.12.1.2 - 2.415.el6_5.9
LIBVIRT Version: libvirt-0.10.2-29.el6_5.7
VDSM Version: vdsm-4.14.7-2.el6ev

The environment:
1 REAL DC - 1 FAKE DC
1 REAL Cluster - 1 FAKE Cluster
1 REAL SD - 10 FAKE SDs 
50 REAL VMs (4CPU - 2G RAM)
1 REAL HOST - 50 Fake HOSTS

Created 80 LUNs on XtreamIO iSCSI storage.
Each FAKE SD has 8 LUNs.

"The thread pool is out of limit" didn't appear.

See Bug 1106572 - [scale] [storage] ConnectStorageServer failed - The thread pool is out of limit (engine finish its thread pool)
for more details
Comment 10 Eyal Edri 2014-08-05 04:25:51 EDT
all these bugs were fixed and released as part of 3.4.1,
and weren't closed since they weren't included in any errata.
closing as current release.

Note You need to log in before you can comment on or make changes to this bug.