Bug 1007403 - horizon [Havana]: unclear error when trying to launch instance after session expired
horizon [Havana]: unclear error when trying to launch instance after session ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
x86_64 Linux
unspecified Severity medium
: rc
: 4.0
Assigned To: Matthias Runge
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 08:24 EDT by Dafna Ron
Modified: 2013-12-19 19:24 EST (History)
6 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-3.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:24:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (45 bytes, application/x-gzip)
2013-09-12 08:24 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1214812 None None None Never

  None (edit)
Description Dafna Ron 2013-09-12 08:24:24 EDT
Created attachment 796834 [details]
logs

Description of problem:

if we try to launch and instance after session has expired we get the following error: 
Error: An error occurred. Please try again later.

only after we move between the tabs we are logged out 

Version-Release number of selected component (if applicable):

python-django-horizon-2013.2-0.10b3.el6.noarch

How reproducible:

100%

Steps to Reproduce:
1. select the instance tab under Admin tab
2. let the session expire 
3. try to launch an instance 

Actual results:

we get: Error: An error occurred. Please try again later. instead of user being logged out

Expected results:

we should log out the expired session or add a more informative error 

Additional info:
Comment 2 Matthias Runge 2013-10-01 03:31:28 EDT
Should be fixed in rc1, we have currently no build.
Comment 3 Matthias Runge 2013-11-13 05:51:37 EST
The situation shouldn't be reproducible at all.
Comment 5 Ami Jeain 2013-11-21 05:18:27 EST
verified it works properly in the latest puddle (RHOS beta).
no error, just relogin page
Comment 7 Matthias Runge 2013-12-10 02:26:46 EST
no docs required here.
Comment 9 errata-xmlrpc 2013-12-19 19:24:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.