Bug 1007434 - [abrt] iftop-1.0-0.4.pre2.fc19: __assert_fail_base: Process /usr/sbin/iftop was killed by signal 6 (SIGABRT)
Summary: [abrt] iftop-1.0-0.4.pre2.fc19: __assert_fail_base: Process /usr/sbin/iftop w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iftop
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a86d553b8f7a64de2bbcc52b7af...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-12 13:30 UTC by Evgeny
Modified: 2014-01-03 22:42 UTC (History)
3 users (show)

Fixed In Version: iftop-1.0-0.6.pre2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-21 02:08:47 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (12.23 KB, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: core_backtrace (9.38 KB, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: dso_list (1.43 KB, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: environ (2.29 KB, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: maps (6.99 KB, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: open_fds (213 bytes, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: proc_pid_status (902 bytes, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details
File: var_log_messages (227 bytes, text/plain)
2013-09-12 13:30 UTC, Evgeny
no flags Details

Description Evgeny 2013-09-12 13:30:15 UTC
Version-Release number of selected component:
iftop-1.0-0.4.pre2.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        iftop -i wlp4s0
crash_function: __assert_fail_base
executable:     /usr/sbin/iftop
kernel:         3.10.10-200.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (9 frames)
 #2 __assert_fail_base at assert.c:92
 #3 __assert_fail at assert.c:101
 #4 PROTO_ADDRESS_SIZE at ../src/nss-myhostname/ifconf.h:44
 #6 _nss_myhostname_gethostbyaddr2_r at ../src/nss-myhostname/nss-myhostname.c:445
 #7 _nss_myhostname_gethostbyaddr_r at ../src/nss-myhostname/nss-myhostname.c:526
 #8 __gethostbyaddr_r at ../nss/getXXbyYY_r.c:263
 #9 do_resolve at resolver.c:123
 #10 resolver_worker at resolver.c:423
 #12 clone at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Comment 1 Evgeny 2013-09-12 13:30:24 UTC
Created attachment 796854 [details]
File: backtrace

Comment 2 Evgeny 2013-09-12 13:30:27 UTC
Created attachment 796855 [details]
File: cgroup

Comment 3 Evgeny 2013-09-12 13:30:30 UTC
Created attachment 796856 [details]
File: core_backtrace

Comment 4 Evgeny 2013-09-12 13:30:33 UTC
Created attachment 796857 [details]
File: dso_list

Comment 5 Evgeny 2013-09-12 13:30:36 UTC
Created attachment 796858 [details]
File: environ

Comment 6 Evgeny 2013-09-12 13:30:40 UTC
Created attachment 796859 [details]
File: limits

Comment 7 Evgeny 2013-09-12 13:30:43 UTC
Created attachment 796860 [details]
File: maps

Comment 8 Evgeny 2013-09-12 13:30:49 UTC
Created attachment 796861 [details]
File: open_fds

Comment 9 Evgeny 2013-09-12 13:30:53 UTC
Created attachment 796862 [details]
File: proc_pid_status

Comment 10 Evgeny 2013-09-12 13:30:56 UTC
Created attachment 796863 [details]
File: var_log_messages

Comment 11 Robert Story 2013-11-04 18:51:08 UTC
This one has been around for a while.. See also: bz#961236, bz#868065, bz#861582, bz#839750

work around is to turn of dns resoltion

Comment 12 Tomas Heinrich 2013-11-14 15:59:57 UTC
Robert, this problem has been sitting here for quite some time; your last comment on this is from 2012-08-10. Has there been any progress since then? Did you get any reply from the upstream?

iftop keeps crashing short while after it is started which makes it almost unusable.

Comment 13 Robert Scheck 2013-11-16 18:55:18 UTC
Tomas, thank you for reminding me. Indeed upstream has replied (which I did
unfortunately overlook) however asked for further information. Meanwhile, I
found a patch that should solve this issue. Can you please try one of these
scratch builds please and give me some feedback?

 - F21: http://koji.fedoraproject.org/koji/taskinfo?taskID=6187796
 - F20: http://koji.fedoraproject.org/koji/taskinfo?taskID=6188542
 - F19: http://koji.fedoraproject.org/koji/taskinfo?taskID=6188556
 - F18: http://koji.fedoraproject.org/koji/taskinfo?taskID=6188569
 - EL6: http://koji.fedoraproject.org/koji/taskinfo?taskID=6188587
 - EL5: http://koji.fedoraproject.org/koji/taskinfo?taskID=6188595

From what I get when trying to get myself into this as a non-programmer, it
looks like there are two different issues, a memory-leak related to DNS and
one from nss-myhostname/glibc, where the second is:

- https://bugzilla.novell.com/show_bug.cgi?id=791101
- https://bugzilla.redhat.com/show_bug.cgi?id=756441
- http://www.sourceware.org/bugzilla/show_bug.cgi?id=9954

Comment 14 Tomas Heinrich 2013-11-18 12:09:25 UTC
Tried the f20 one and it still crashes, unfortunately.

I hope to have more time later to look at the code.

Comment 15 Robert Scheck 2013-12-18 23:22:25 UTC
Tomas, I think I was able to track the second issue down as well. However I
am personally unable to reproduce the issue at all. Can you please try one of
these scratch builds please and give me some feedback?

 - F21: http://koji.fedoraproject.org/koji/taskinfo?taskID=6311472
 - F20: http://koji.fedoraproject.org/koji/taskinfo?taskID=6311487
 - F19: http://koji.fedoraproject.org/koji/taskinfo?taskID=6311493
 - F18: http://koji.fedoraproject.org/koji/taskinfo?taskID=6311501

As this second issue is specific to nss-myhostname it does not affect RHEL 5
and 6, thus I will not provide any scratch builds therefore.

Comment 16 Tomas Heinrich 2013-12-19 16:40:53 UTC
(In reply to Robert Scheck from comment #15)
> Tomas, I think I was able to track the second issue down as well. However I
> am personally unable to reproduce the issue at all. Can you please try one of
> these scratch builds please and give me some feedback?

Looks promising.
I've tried the f20 build and it didn't crash on me yet (10 mins so far).
Given the old version crashed after ~10 sec, I'm inclined to say you've fixed it for good.

Comment 17 Robert Scheck 2013-12-19 16:44:00 UTC
I am going to push this update tonight - given that I also got positive
feedback in another RHBZ. In case the issue is still not fixed I am quite
sure somebody either opens a new bug report or comments on one of these
"zillions" existing ones then linked with the update in Bodhi.

Comment 18 John Schmitt 2013-12-19 18:06:57 UTC
iftop-1.0-0.6.pre2.fc21.x86_64
3.12.3-1.fc21.x86_64

Been running well for about 18 hours.

Comment 19 Fedora Update System 2013-12-19 19:15:31 UTC
iftop-1.0-0.6.pre2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/iftop-1.0-0.6.pre2.fc20

Comment 20 Fedora Update System 2013-12-19 19:16:35 UTC
iftop-1.0-0.6.pre2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/iftop-1.0-0.6.pre2.fc19

Comment 21 Fedora Update System 2013-12-19 19:17:41 UTC
iftop-1.0-0.6.pre2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/iftop-1.0-0.6.pre2.fc18

Comment 22 Fedora Update System 2013-12-19 19:19:06 UTC
iftop-1.0-0.6.pre2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/iftop-1.0-0.6.pre2.el6

Comment 23 Fedora Update System 2013-12-19 19:20:06 UTC
iftop-1.0-0.6.pre2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/iftop-1.0-0.6.pre2.el5

Comment 24 Fedora Update System 2013-12-20 16:52:17 UTC
Package iftop-1.0-0.6.pre2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing iftop-1.0-0.6.pre2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12431/iftop-1.0-0.6.pre2.el6
then log in and leave karma (feedback).

Comment 25 Fedora Update System 2013-12-21 02:08:47 UTC
iftop-1.0-0.6.pre2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2013-12-21 18:50:43 UTC
iftop-1.0-0.6.pre2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2013-12-23 03:50:50 UTC
iftop-1.0-0.6.pre2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2013-12-28 23:42:31 UTC
iftop-1.0-0.6.pre2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2014-01-03 22:42:56 UTC
iftop-1.0-0.6.pre2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.