Bug 1007448 - Anaconda in netinst won't proceed to next screen (or is very slow)
Anaconda in netinst won't proceed to next screen (or is very slow)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20AlphaFreezeException F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-09-12 09:58 EDT by Lukas Brabec
Modified: 2013-09-18 22:39 EDT (History)
13 users (show)

See Also:
Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:39:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
problem on video (162.03 KB, video/ogg)
2013-09-12 09:58 EDT, Lukas Brabec
no flags Details

  None (edit)
Description Lukas Brabec 2013-09-12 09:58:18 EDT
Created attachment 796872 [details]
problem on video

Description of problem:
After selecting language in anaconda, there is a white background shown and anaconda wont't proceed to next screen (virtualized) or is extremly slow (bare hardware)

Version-Release number of selected component (if applicable):
Fedora 20 Alpha RC2 (both 32 and 64bit)


Steps to Reproduce:
1. Boot netinst
2. Select language and be ok with your fate

Actual results:
White background is shown and nothing else happens

Expected results:
Next screen of setup should be shown
Comment 1 Kamil Páral 2013-09-12 10:07:16 EDT
Actually it proceeds to the next screen eventually, even in VM. It just takes a long time (30 seconds or more). I guess it depends on the network speed and mirror selection. My guess is that anaconda threading is broken somewhere and the GUI waits until a (part of) metadata is downloaded, only then it is refreshed.

This occurs on both architectures, VM and bare metal. There's no such problem with DVD. Proposing as a Final blocker and an Alpha freeze exception.

Lukas, please wait until the screen is refreshed and then append logs, thanks.
Comment 2 satellitgo 2013-09-12 10:17:46 EDT
It does have white screen after language screen but only 5-10 sec here in VirtualBox on i7 with cable access. (RC-2 x86_64 boot from.iso -1440 memory in VB)
Comment 3 Andre Robatino 2013-09-12 10:53:49 EDT
Yes, it took a very long time for me with the netinst (over a minute with my 3 Mb/s DSL) but eventually proceeded. With the DVD, it proceeds quickly, presumably since it doesn't have to download.
Comment 4 Fedora Update System 2013-09-13 21:04:16 EDT
anaconda-20.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.16-1.fc20
Comment 5 Fedora Update System 2013-09-14 13:45:48 EDT
Package anaconda-20.16-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.16-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16735/anaconda-20.16-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-09-16 13:47:04 EDT
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20
Comment 7 Lukas Brabec 2013-09-17 04:30:20 EDT
Seems that anaconda 20.17-1 solved the problem for me
Comment 8 Kamil Páral 2013-09-17 09:09:25 EDT
Yes, F20 Alpha RC3 netinst is quick again when showing the main screen.
Comment 9 Mike Ruckman 2013-09-18 15:19:49 EDT
Discussed in 2013-09-18 blocker review meeting [1]. While not a release blocking issue, this bug is an annoyance and would be good to fix before f20 alpha release. A tested fix would be considered past freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-18/
Comment 10 Fedora Update System 2013-09-18 22:39:33 EDT
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.