Bug 1007454 - [RFE] Show the gears UUID when calling oo-admin-ctl-app
[RFE] Show the gears UUID when calling oo-admin-ctl-app
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.2.1
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miheer Salunke
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 10:09 EDT by Nick Harvey
Modified: 2017-03-08 12 EST (History)
9 users (show)

See Also:
Fixed In Version: openshift-origin-broker-util-1.23.8.4-1.el6op
Doc Type: Bug Fix
Doc Text:
Previously, using the oo-admin-ctl-app command with the `-c status` option only returned the state of the application and any of its add-on cartridges, for example whether they were running or stopped. This bug fix updates the oo-admin-ctl-app command and now the `-c status` option also returns the application UUID and each of its gear UUIDs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-23 03:37:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Harvey 2013-09-12 10:09:22 EDT
Description of problem: The Customer would like to see the gears UUID when they ran the following command in the broker:

oo-admin-ctl-app  -l ansilva@REDHAT.COM -a test -c status
Application is running
%


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. login to the broker
2. Execute the command 

Actual results:


Expected results: the gears UUID


Additional info:
Comment 2 Miciah Dashiel Butler Masters 2014-06-13 11:02:11 EDT
Miheer is taking this bug.

Nick, please clarify how you want this to work in applications with multiple gears.  Do you want oo-admin-ctl-app to print all of the application's gears' UUIDs, or do you only want it to print the application's UUID (which coïncidentally is the first gear's UUID)?
Comment 3 Miciah Dashiel Butler Masters 2014-06-13 16:51:37 EDT
Miheer has fixed this bug upstream and backported his fix to enterprise-server/enterprise-2.1.

PR: https://github.com/openshift/enterprise-server/pull/300

commit bc9ae480f08da83ff8fa63cd5db9390d452a98c3
Author: Miheer Salunke <misalunk@redhat.com>
Date:   2014-06-13 21:46:20 +0530

    oo-admin-ctl-app: show app/gear UUID with status

    Make oo-admin-ctl-app  -l <username@EXAMPLE.COM> -a test -c status display the application's and its gear's UUIDs.

    enterprise-server bug 1007454
    origin-server #cherrypick
    origin-server commit 5fc2d17c1a978c6838d01bffe97430eceffd0173
Comment 6 Jason DeTiberus 2014-06-18 15:12:10 EDT
http://etherpad.corp.redhat.com/puddle-2-1-2014-06-18
Comment 7 Yanping Zhang 2014-06-19 03:36:55 EDT
Verified on 2.1.z/2014-06-18.2
Steps to verify:
1.Create an app;
# rhc app create php1 php-5.4
2.On the broker ,view the app with oo-admin-ctl-app command.
[root@broker ~]# oo-admin-ctl-app -l ypzh -a php1 -c status

Actual results:
2.[root@broker ~]# oo-admin-ctl-app -l ypzh -a php1 -c status
Application UUID is 53a27112db26c899db000009
GEAR UUID is 53a27112db26c899db000009
Application is running
%

In the output, app and gear's UUID displayed correctly.
Comment 9 errata-xmlrpc 2014-06-23 03:37:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0781.html

Note You need to log in before you can comment on or make changes to this bug.