Bug 1007493 - shipped fonts.alias includes references to missing sazanami-times font
Summary: shipped fonts.alias includes references to missing sazanami-times font
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sazanami-fonts
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1084799 1154295 (view as bug list)
Depends On: 1009350
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-12 15:10 UTC by Sean Burke
Modified: 2014-12-15 09:00 UTC (History)
7 users (show)

Fixed In Version: sazanami-fonts-0.20040629-23.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-27 08:35:34 UTC


Attachments (Terms of Use)
The log of fontforge error message while launching. (1.27 KB, text/plain)
2014-12-11 13:15 UTC, N.Brack
no flags Details

Description Sean Burke 2013-09-12 15:10:58 UTC
fonts.alias in the sazanami package is reporting the existence of a sazanami-times font face to Xorg which does not appear to exist. This is causing problems in other packages.

Comment 1 Sean Burke 2013-09-12 15:43:58 UTC
A similar problem exists in sazanami-gothic with sazanami-helvetica being in fonts.alias.

Comment 2 Akira TAGOH 2013-09-13 03:06:58 UTC
What kind of problems does this cause? it should simply works as long as applications builds the appropriate XFontSet.

Comment 3 Sean Burke 2013-09-13 03:14:32 UTC
It causes a crash in fontforge initialization. See https://bugzilla.redhat.com/show_bug.cgi?id=1007477

Comment 4 Akira TAGOH 2013-09-18 09:21:57 UTC
I suppose this issue should be gone after removing the lines for jisx0201.1976-0 charsets. it is a bug in ttmkfdir. I just filed it.

Comment 5 Kevin Fenzi 2014-04-11 19:14:40 UTC
*** Bug 1084799 has been marked as a duplicate of this bug. ***

Comment 6 Kevin Fenzi 2014-04-11 19:15:17 UTC
Still happening now with fedora 20. ;(

Comment 7 N.Brack 2014-05-02 12:49:31 UTC
I confirm I also have the same bug !
Specifically, after installing sazanami, xlsfonts list the fonts :

-sazanami-fixed-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0
-sazanami-gothic-medium-r-normal--0-0-0-0-c-0-iso8859-1
-sazanami-gothic-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0
-sazanami-helvetica-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0
-sazanami-mincho-medium-r-normal--0-0-0-0-c-0-iso8859-1
-sazanami-mincho-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0
-sazanami-times-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0

Which cause fontforge to crash.

Rebuilding the cache cannot help in any way; I uninstalled the fonts, and the broken ones were not there anymore, only to reappear when I reinstalled the fonts.

Comment 8 Kevin Fenzi 2014-10-18 16:32:13 UTC
*** Bug 1154295 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2014-11-17 11:01:47 UTC
sazanami-fonts-0.20040629-23.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sazanami-fonts-0.20040629-23.fc20

Comment 10 Fedora Update System 2014-11-18 12:23:06 UTC
Package sazanami-fonts-0.20040629-23.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sazanami-fonts-0.20040629-23.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15296/sazanami-fonts-0.20040629-23.fc20
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2014-11-27 08:35:34 UTC
sazanami-fonts-0.20040629-23.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 N.Brack 2014-12-03 02:54:30 UTC
The problem still persists with me.
First, there is no sazanami-fonts package whatsoever to be found in the repositories, only :

    sazanami-fonts-common.noarch
    sazanami-gothic-fonts.noarch
    sazanami-mincho-fonts.noarch

Repoquery claims I have version 20040629-23 for those packages :

    Name        : sazanami-gothic-fonts
    Version     : 0.20040629
    Release     : 23.fc20

But I still have the same error with fontforge when starting, and xlsfonts still list fonts starting with "-sazanami-...", althoug alongside with other fonts listing "-misc-sazanami-...".  Removing the packages still remove the "-sazanami" fonts and reinstalling stil add those buggy descriptors again.

    ...
    -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-suneu-greek
    -sazanami-fixed-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0
    ...

Comment 13 Akira TAGOH 2014-12-05 03:35:14 UTC
works for me. fonts.scale in the package has no problem and contains expected XLFDs. I suppose you don't have an updated xorg-x11-fonts-misc package installed?

Comment 14 N.Brack 2014-12-05 17:58:21 UTC
Nope.  I actually haven't xorg-x11-fonts-misc installed at all, only the sazanami ones.

Installing xorg-x11-fonts-misc at version "xorg-x11-fonts-7.5-10.fc20" doesn't solve the issue (and quite hopefully, else I don't understand a think of what's going on)

Comment 15 Akira TAGOH 2014-12-08 06:12:44 UTC
I'm not sure where -suneu-greek charset was coming. correct entries in fonts.scale should be:
8
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-ascii-0
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso10646-1
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso8859-1
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso8859-15
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso8859-9
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-jisx0208.1990-0

You can try to regenerate them with ttmkfdir.

Comment 16 N.Brack 2014-12-10 10:36:26 UTC
The -suneu-greek charset is found with the mincho declinaison of the font, not the gothic one, in /usr/share/fonts/sazanami/mincho/fonts.dir.


However I found the guilty descriptors in files named "fonts.alias" :

/usr/share/fonts/sazanami/mincho/fonts.alias:1:-sazanami-times-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0       "-misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0"
/usr/share/fonts/sazanami/mincho/fonts.alias:2:-sazanami-times-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0       "-misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0"
/usr/share/fonts/sazanami/mincho/fonts.alias:3:-sazanami-mincho-medium-r-normal--0-0-0-0-c-0-iso8859-1            "-misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-1"
/usr/share/fonts/sazanami/mincho/fonts.alias:4:-sazanami-mincho-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0      "-misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0"
/usr/share/fonts/sazanami/mincho/fonts.alias:5:-sazanami-mincho-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0      "-misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0"

/usr/share/fonts/sazanami/gothic/fonts.alias:1:-sazanami-helvetica-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0   "-misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0"
/usr/share/fonts/sazanami/gothic/fonts.alias:2:-sazanami-helvetica-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0   "-misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0"
/usr/share/fonts/sazanami/gothic/fonts.alias:3:-sazanami-fixed-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0       "-misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0"
/usr/share/fonts/sazanami/gothic/fonts.alias:4:-sazanami-fixed-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0       "-misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0"
/usr/share/fonts/sazanami/gothic/fonts.alias:5:-sazanami-gothic-medium-r-normal--0-0-0-0-c-0-iso8859-1            "-misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-iso8859-1"
/usr/share/fonts/sazanami/gothic/fonts.alias:6:-sazanami-gothic-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0      "-misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0"
/usr/share/fonts/sazanami/gothic/fonts.alias:7:-sazanami-gothic-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0      "-misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0"

I'm not sure what to do though.

Comment 17 Akira TAGOH 2014-12-11 03:10:03 UTC
No problem here with both fonts installed. what exactly does fontforge say?

Comment 18 N.Brack 2014-12-11 13:15:27 UTC
Created attachment 967230 [details]
The log of fontforge error message while launching.

Here is the output of fontforge.

Comment 19 Akira TAGOH 2014-12-15 09:00:23 UTC
Well, -sazanami-times-medium-r-normal--*-0-0-0-c-0-jisx0201.1976-0 is mentioned at fonts.alias in sazanami-mincho-fonts:

-sazanami-times-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0       "-misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0"

and the entity is included in fonts.scale/fonts.dir in sazanami-mincho-fonts too:

sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0

which yours somehow may not, right?
if it's there but still happens, try restarting X server or X font server if you use.


Note You need to log in before you can comment on or make changes to this bug.