Bug 1007497 - Openstack Installer: packstack does not create tables in Heat db.
Openstack Installer: packstack does not create tables in Heat db.
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Francesco Vollero
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 11:21 EDT by Nir Magnezi
Modified: 2016-04-26 22:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.10.dev763.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:01:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packstack answer file (13.27 KB, text/plain)
2013-09-12 11:21 EDT, Nir Magnezi
no flags Details
Heat Engine Log (31.23 KB, text/x-log)
2013-09-12 11:21 EDT, Nir Magnezi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 46945 None None None Never

  None (edit)
Description Nir Magnezi 2013-09-12 11:21:10 EDT
Created attachment 796916 [details]
packstack answer file

Description of problem:
=======================
packstack does not create tables in head db.
As a result of that, The openstack-heat-engine service failed to start

Version-Release number of selected component (if applicable):
=============================================================
openstack-packstack-2013.2.1-0.9.dev756.el6.noarch

How reproducible:
=================
1/1

Steps to Reproduce:
===================
1. Install Openstack via packstack, Use the answer file attached to this mail as a template.
2. Check Heat Engine status:
$ service openstack-heat-engine status
heat-engine dead but pid file exists

3. Check Heat DB:

mysql> use heat;
Database changed
mysql> show tables;
Empty set (0.00 sec)


Actual results:
===============
openstack-heat-engine service failed to start with the following error:

ProgrammingError: (ProgrammingError) (1146, "Table 'heat.stack' doesn't exist") 'SELECT stack.created_at AS stack_created_at, stack.updated_at AS stack_updated_at, stack.deleted_at AS stack_deleted_at, stack.id AS stack_id, stack.name AS stack_name, stack.raw_template_id AS stack_raw_template_id, stack.username AS stack_username, stack.tenant AS stack_tenant, stack.action AS stack_action, stack.status AS stack_status, stack.status_reason AS stack_status_reason, stack.parameters AS stack_parameters, stack.user_creds_id AS stack_user_creds_id, stack.owner_id AS stack_owner_id, stack.timeout AS stack_timeout, stack.disable_rollback AS stack_disable_rollback \nFROM stack \nWHERE stack.deleted_at IS NULL AND stack.owner_id IS NULL' ()
2013-09-12 17:50:06.459 15663 TRACE heat.openstack.common.threadgroup

Expected results:
=================
Heat should be fully functional post installation via packstack.
Comment 1 Nir Magnezi 2013-09-12 11:21:58 EDT
Created attachment 796917 [details]
Heat Engine Log
Comment 2 Steven Hardy 2013-09-16 10:19:26 EDT
Confirmed, I see this too on F19:

openstack-packstack-2013.2.1-0.9.dev756.fc20.noarch

Looks like we're missing this upstream fix:

https://github.com/packstack/puppet-
heat/commit/001363c478f4b59acd499d77b70d780052a8ced1

Workaround is:

1. heat-manage db_sync
2. systemctl start openstack-heat-engine.service

Note You need to log in before you can comment on or make changes to this bug.