Bug 1007499 - JAR file in project's dependencies disappears after server reboot
JAR file in project's dependencies disappears after server reboot
Status: CLOSED DUPLICATE of bug 985039
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Toni Rikkola
Radovan Synek
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-12 11:23 EDT by Radovan Synek
Modified: 2013-09-13 03:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 03:59:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Synek 2013-09-12 11:23:45 EDT
Description of problem:
After importing a jar to project - as dependency - and rebooting server, the jar is no more listed in project's dependencies.

Version-Release number of selected component (if applicable):
BRMS-6.0.0.ER2

Steps to Reproduce:
1. upload jar into Authoring -> Asset repository
2. add this jar to your project's dependencies (via 'Add from repository' button)
3. logout, restart server, login
4. check your project's dependencies - there is no such jar. Add it from repository once more - you've got 2 dependencies on the same jar.

Additional info:
It seems the jar didn't disappear completely - its classes were available in data modeller, but it vanished from Project screen -> Dependencies. 
Nothing interesting in the server log
Comment 2 Radovan Synek 2013-09-13 03:59:09 EDT

*** This bug has been marked as a duplicate of bug 985039 ***

Note You need to log in before you can comment on or make changes to this bug.