Bug 1007509 - Add Brick Does Not Clear xttr's
Add Brick Does Not Clear xttr's
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.4.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks: 960069 1045991
  Show dependency treegraph
 
Reported: 2013-09-12 11:48 EDT by Vijay Bellur
Modified: 2014-04-17 07:47 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 960069
: 1045991 (view as bug list)
Environment:
Last Closed: 2014-04-17 07:47:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2013-09-12 11:48:28 EDT
When trying to add bricks to a volume, if the bricks had been previously used, the add can fail due to fattr's and residual /bricks/app/.glusterfs files.



How reproducible:
Always

Steps to Reproduce:
1. Select a brick that was previously used to add to a new volume
2. Attempt to add that brick
  
Actual results:
Add fails with error messages similar to below
/bricks/app or a prefix of it is already part of a volume

Expected results:
Add works correctly with the fattr's and files removed/set properly.
Comment 1 Anand Avati 2013-09-25 13:43:15 EDT
REVIEW: http://review.gluster.org/5746 (mgmt/glusterd: Relax extended attribute checks for volume create and add brick force.) posted (#4) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 2 Anand Avati 2013-10-17 20:16:28 EDT
COMMIT: http://review.gluster.org/5746 committed in master by Anand Avati (avati@redhat.com) 
------
commit b2a9cbe5ce61ce170a55fb3dfd7f2d6de9c52f97
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Sat Aug 31 22:34:02 2013 +0530

    mgmt/glusterd: Relax extended attribute checks for volume create and add brick force.
    
    Expectation with force is that user is aware of the consequences of
    sanity checks not being triggered.
    
    Change-Id: I79dfeed16a23829a7217cef33ab83f9f0ffae336
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    BUG: 1007509
    Reviewed-on: http://review.gluster.org/5746
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:47:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.