Bug 1007583 - Globally uncaught exception is thrown whenever 1h, 4h,8h etc. buttons are clicked for the deployed soap app
Globally uncaught exception is thrown whenever 1h, 4h,8h etc. buttons are cli...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: JON (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: ER3
: 6.0.0
Assigned To: kconner
Tomas Plevko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 15:55 EDT by Varun Khurana
Modified: 2014-02-06 10:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:25:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (167.47 KB, image/png)
2013-09-12 15:55 EDT, Varun Khurana
no flags Details
Screenshot2 (196.86 KB, image/png)
2013-09-12 15:56 EDT, Varun Khurana
no flags Details

  None (edit)
Description Varun Khurana 2013-09-12 15:55:14 EDT
Created attachment 796991 [details]
Screenshot

Description of problem:
Globally uncaught exception is thrown whenever 1h, 4h,8h etc. buttons are clicked for the deployed soap app.

Version-Release number of selected component (if applicable):


How reproducible:
most of the times but not always

Steps to Reproduce:
1.Deploy SOAP application to JON 3.2. I deployed Orders quickstart app.
2.Go to JBossAS7 Standalone Servers ->EAP->Switchyard -> Applications -> orders(or whatever the name of your quickstart) -> Services -> Service bindings -> OrderWebService_Soap_1. 
3.Click on Monitoring-> Metrics.
4. Click on 1h,4h or 8h etc. buttons

Actual results:
You get globally Uncaught Exception at the page.

Expected results:
You should not get Globally Uncaught Exception on the page.

Additional info:

Message :	
Globally uncaught exception
Severity :Error

Time :	
Thursday, September 12, 2013 3:36:11 PM UTC-4
Root Cause :	
(TypeError) : Cannot call method 'getSavedItemValue' of null
Detail :	
com.google.gwt.core.client.JavaScriptException:(TypeError) : Cannot call method 'getSavedItemValue' of null
--- STACK TRACE FOLLOWS ---
(TypeError) : Cannot call method 'getSavedItemValue' of null
   at Unknown.isc_FormItem_getValue(http://10.16.23.193:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@18)
   at Unknown.isc_FormItem_updateValueMap(http://10.16.23.193:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@127)
   at Unknown.isc_FormItem_setValueMap(http://10.16.23.193:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@80)
   at Unknown.isc_c_Class_invokeSuper(http://10.16.23.193:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js@93)
   at Unknown.isc_c_Class_Super(http://10.16.23.193:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js@170)
   at Unknown.isc_SelectItem_setValueMap(http://10.16.23.193:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@63)
   at Unknown.$setValueMapMethod(<anonymous>@10)
   at Unknown.$setValueMap(<anonymous>@29)
   at Unknown.setValueMap(<anonymous>@3)
   at Unknown.$onSuccess_416(<anonymous>@44)
Comment 1 Varun Khurana 2013-09-12 15:56:02 EDT
Created attachment 796992 [details]
Screenshot2
Comment 3 kconner 2013-09-18 16:36:42 EDT
I cannot reproduce this using the 1.0.0-redhat-2 tag however it was seen using 1.0.0-redhat-1.  The provision of the metrics is now under direct control of the SY JON plugin and this appears to have fixed the issue.
Comment 7 Tomas Plevko 2013-10-23 07:59:05 EDT
Verified. JON 3.2 ER3 + SOA6 ER4 + jon-plugin-pack-soa-3.2.0.ER3

Note You need to log in before you can comment on or make changes to this bug.