Bug 1007611 - rdesktop can't connect to VirtualBox any more (already fixed upstream)
rdesktop can't connect to VirtualBox any more (already fixed upstream)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 19:39 EDT by James Heather
Modified: 2014-10-28 13:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: rdesktop-1.8.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-24 21:36:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Heather 2013-09-12 19:39:26 EDT
Description of problem:

rdesktop can't connect to virtual machines in recent versions of VirtualBox:

  Failed to negotiate protocol, retrying with plain RDP.

and then it gives up.

Version-Release number of selected component (if applicable):

rdesktop-1.8.0-1.fc19.x86_64

Additional info:

This is already fixed upstream, so it just needs the Fedora RPM to be updated with the new upstream stuff.

https://bugs.archlinux.org/task/36488
Comment 1 Dominik 'Rathann' Mierzejewski 2013-12-22 19:38:54 EST
Looks like this is fixed in 1.8.1. I'll update soon.
Comment 2 Fedora Update System 2013-12-22 20:15:16 EST
rdesktop-1.8.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rdesktop-1.8.1-1.fc20
Comment 3 Fedora Update System 2013-12-22 20:15:42 EST
rdesktop-1.8.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rdesktop-1.8.1-1.fc19
Comment 4 Fedora Update System 2013-12-23 22:40:08 EST
Package rdesktop-1.8.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rdesktop-1.8.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23910/rdesktop-1.8.1-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-12-24 21:36:42 EST
rdesktop-1.8.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2014-01-01 04:00:01 EST
rdesktop-1.8.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 le.dahut 2014-03-18 10:22:56 EDT
The problem still persists :

 rpm -qa|grep rdesk
 rdesktop-1.8.1-1.fc20.i686

 rdesktop vboxhost
 Autoselected keyboard map fr
 Failed to negotiate protocol, retrying with plain RDP.
Comment 8 Colin Guthrie 2014-04-02 06:09:45 EDT
Yeah I'm also seeing the same issue with rdesktop trunk and VirtualBox. Using the older version 1.7.0 works fine so I guess it's the new negotiation code upstream.
Comment 9 Colin Guthrie 2014-04-02 06:24:47 EDT
Meant to say in previous message that this seems like a problem reported upstream too: http://sourceforge.net/p/rdesktop/mailman/message/32115618/

Alternative option is to use freerdp instead.
Comment 10 Ian Collier 2014-08-31 20:09:11 EDT
Not sure if this is related, but rdesktop 1.8.1 won't refresh its screen properly when connected to a Windows VM in VirtualBox, whereas rdesktop 1.7.1 works perfectly well.  It does sound like that upstream bug report is relevant.

Version 1.8.0 wouldn't start at all, whereas 1.8.1 does connect and show what's on the screen at the time of connection, but if I hide and re-expose the rdesktop window it's all black.

Note You need to log in before you can comment on or make changes to this bug.