This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1007686 - Migration command in vdsClient doesn't include dstqemu field in its command description
Migration command in vdsClient doesn't include dstqemu field in its command d...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.5.0
Assigned To: Mooli Tayer
Martin Pavlik
network
: Rebase, Triaged
Depends On:
Blocks: rhev3.5beta 1156165
  Show dependency treegraph
 
Reported: 2013-09-13 02:51 EDT by Yaniv Bronhaim
Modified: 2016-02-10 14:47 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-3.5
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-22 13:34:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19277 None None None Never
oVirt gerrit 24009 None None None Never

  None (edit)
Description Yaniv Bronhaim 2013-09-13 02:51:01 EDT
Description of problem:
dstqemu is a new field entered in 3.3, this field states the ip address of the migration network from which to perform a migration from. This field is not stated while using vdsClient:

Migrate
        vmId=<id> method=<offline|online> src=<host:[port]> dst=<host:[port]>
        Migrate a desktop from src machine to dst host using the specified ports

Version-Release number of selected component (if applicable):
vdsm-4.12.0-115.git10c6a27.el6.x86_64

Actual results:
The new field should be provided and explained in the command description.
Comment 1 Michal Skrivanek 2013-09-16 04:48:09 EDT
since this is a new network feature and Mooli's going to work on it, moving to network
Comment 2 Dan Kenigsberg 2013-09-16 06:45:54 EDT
not a blocker, taking to 3.4.
Comment 3 Meni Yakove 2013-10-10 08:15:29 EDT
dstqemu exist but no explanation provided.

migrate
        vmId=<id> method=<offline|online> src=<host[:port]> dst=<host[:port]>  dstqemu=<host>
        Migrate a desktop from src machine to dst host using the specified ports
Comment 4 Mooli Tayer 2014-02-03 08:58:36 EST
How is:

migrate
        vmId=<id> method=<offline|online> src=<host[:port]> dst=<host[:port]>  dstqemu=<host>
        Migrate a desktop from src machine to dst host using the specified ports and an optional migration-dedicated network
Comment 5 Dan Kenigsberg 2014-02-03 09:09:12 EST
I'd say "migration-dedicated IP address" since you pass an address, not a network name.
Comment 6 Mooli Tayer 2014-02-03 09:54:08 EST
Maybe 'migration-dedicated address' since it's ip/host?
Comment 7 Mooli Tayer 2014-02-03 10:02:22 EST
or just 'migration address'?
Comment 8 Dan Kenigsberg 2014-02-03 11:19:37 EST
'and an optional address for migration data traffic'
Comment 9 Martin Pavlik 2014-03-12 04:01:16 EDT
1)

Seems like http://gerrit.ovirt.org/#/c/24009/2/

did not really make it to av2.1

this is what I get

migrate
	vmId=<id> method=<offline|online> src=<host[:port]> dst=<host[:port]>  dstqemu=<host>
	Migrate a desktop from src machine to dst host using the specified ports


2)

IMHO using migrate without parameters should return usage (and maybe some hint on what is workng) but not an ugly exception as bellow, do I need to open separate BZ?

[root@dell-r210ii-05 ~]# vdsClient -s 0 migrate
Traceback (most recent call last):
  File "/usr/share/vdsm/vdsClient.py", line 2578, in <module>
    code, message = commands[command][0](commandArgs)
  File "/usr/share/vdsm/vdsClient.py", line 404, in do_migrate
    raise Exception("Not enough parameters")
Exception: Not enough parameters
Comment 10 Dan Kenigsberg 2014-03-22 13:34:47 EDT
This silly bug wastes too much time. It's done upstream, and would be available by ovirt-3.5.

Note You need to log in before you can comment on or make changes to this bug.