Bug 100770 - up2date -update or any other options fails with Python error
Summary: up2date -update or any other options fails with Python error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-25 06:24 UTC by David M Walker
Modified: 2007-03-27 04:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 18:36:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David M Walker 2003-07-25 06:24:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Description of problem:
One of our servers (and noticably not all of them besides the fact they all run
the same version) has started doing this:

# up2date --update
Traceback (innermost last):
  File "/usr/sbin/up2date", line 781, in ?
    main()
  File "/usr/sbin/up2date", line 569, in main
    pkgNames, fullUpdate, dryRun = dry_run))
  File "/usr/sbin/up2date", line 724, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 57, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 89, in
__findPackagesToUpdate
    plist.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 85, in run
    self.addObsoletePackages(obsList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 109, in
addObsoletePackages
    for p in obsoletePackages:
TypeError: loop over non-sequence

The is also true for other options such as up2date --force --download kernel,
which fails with exactly the same message


Version-Release number of selected component (if applicable):
up2date-2.8.39-1.7.3

How reproducible:
Always

Steps to Reproduce:
1. Run up2date --update

    

Actual Results:  As per log file above

Expected Results:  No crash error

Additional info:

Comment 1 David M Walker 2003-07-25 06:39:23 UTC
It turns out that (for reasons not needed here) the channel subscription on
rhn.redhat.com had been set to none, but a more graceful error would be nice


Comment 2 Adrian Likins 2004-08-20 21:11:37 UTC
indeed, current clients handle this better


Note You need to log in before you can comment on or make changes to this bug.