Bug 1007703 - Ability to suspend and resume process instances in UI
Ability to suspend and resume process instances in UI
Status: CLOSED NEXTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mauricio Salatino
Radovan Synek
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-13 03:24 EDT by Radovan Synek
Modified: 2015-12-08 11:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 11:57:17 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Synek 2013-09-13 03:24:36 EDT
User should be able to suspend & resume process instances in UI. Also pending signals should be saved to be executed on resume (they shouldn't be lost during suspend).
Comment 1 Prakash Aradhya 2013-09-16 18:16:35 EDT
As discussed buttons should be added in the process instance view for the user to be able to perform this.

Eventually post-GA, these functions should be moved to a serparate Process Administrator interface where it is access controlled to process admins only.

Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 2 Kris Verlaenen 2013-09-24 11:03:21 EDT
This is currently not planned for 6.0.  The reason is that these are typically admin functions that we believe shouldn't just be exposed to end users.  Saving pending signals would definitely be a future feature.  As a result, offering suspend/resume introduces the risk of signals being lost.  Therefore, we recommend not offering this as part of the end user api.

Note You need to log in before you can comment on or make changes to this bug.