Bug 100771 - VIM runs away
VIM runs away
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-25 02:49 EDT by Shaun Murphy
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 10:26:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaun Murphy 2003-07-25 02:49:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
This problem has been entered here before but none of the really explain the 
exact problem.

Problem: when installing vim-enhanced it creates a alias that profile runs and 
creates alias vi='vim'.  As you can see if you where to run vi it would in turn 
start vim.  This is great except when you loose your remote connection to the 
server or it receives a HANGUP or xterm gets closed when vim's runnign, etc.  
Basically anytime it's tty is lost.  If you where to run the actuall command 
vim this prolblem doesnt exist.  I beleive the reason for this is because maybe 
vim is detecting how it was started and is searching for it's process to kill?  
i dont know for sure.  all i know is the alias is whats causing this problem.  
VIM is not killing it self properly and in turn it consumes 99% CPU until it is 
killed.  This problem has been around for way too long now and is a big problem 
for my type of business (web hosting) as you can imagin many clients log in and 
use vi and alot of them may loose their session.

Here's a strace of what happens when the session is lost.

Version-Release number of selected component (if applicable):
6.1-18.7x.2

How reproducible:
Always

Steps to Reproduce:
1.log into the box via ssh
2.install vim-enhanced
3.ensure the alias vi='vim' exits
4.start vi by typeing vi bugtest
5.close the ssh session with out quiting vi
6.log back in, run top and wala, vim is going crazy

Additional info:
Comment 1 Shaun Murphy 2003-07-25 02:51:18 EDT
Bugzilla wont allow me to past the strace, looks like a bug in bugzilla.
Comment 2 Karsten Hopp 2003-07-31 07:24:08 EDT
I couldn't reproduce this with a current vim, can you please test if the  
vim*7.x* packages from http://people.redhat.com/karsten/ fix this problem ? 
Comment 3 Shaun Murphy 2003-07-31 15:19:06 EDT
Yes, those 7.x packages fixed the problem.  Note that the current vim packages 
i had installed before installing these were the latest from errata.  Can we 
get these released on errata asap if possible.
Comment 4 John Hardin 2003-09-25 13:52:34 EDT
Isn't this a duplicate of bug 83700 ?
Comment 5 Shaun Murphy 2003-09-25 14:33:19 EDT
It's probably the same issue but i give more information about how to duplicate 
the problem.  This issue still has no been resolved.  Whats the deal?  The rpms 
you had me install above seamed to solve the problem but i need a errata update.
Comment 6 John Hardin 2003-09-25 16:26:14 EDT
This does not correct the problem in vim. /bin/vi is a simple version of vim,
probably not compiled with the +python support that causes the runaway process.
If you run vim directly and kill the window, it still goes runaway.

If you don't mind losing the features of vim (like multiwindow editing) killing
the "vi" alias might be a useful workaround.
Comment 7 Shaun Murphy 2003-09-25 18:24:42 EDT
The software should not be running away like this and causing 99% cpu load.  
This is a bug and should be fixed.

Note You need to log in before you can comment on or make changes to this bug.