Bug 1007725 - Same dashbuilder functionality accessible in 2 ways
Same dashbuilder functionality accessible in 2 ways
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER4
: 6.0.0
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-13 04:37 EDT by Jan Hrcek
Modified: 2014-08-06 16:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:06:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-09-13 04:37:41 EDT
Description of problem:
Observation from UX session. There are 2 ways the user can access dashbuilder application from business central. One of them is redundant.

1) Dashboard > Process & Task Dashboard:
-opens dashbuilder workspace 'jBPM Dashboard' integrated as an iframe inside business-central

2) Dashboard > Business dashboard:
-open dashbuilder workspace 'jBPM Dashboard' in new browser tab/window. Unlike in 1, there are some extra features, like access to administration bar (if user has admin role), separate logout button etc.


Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER3

How reproducible:
Always

Steps to Reproduce:
1. Login to business cenral and click both items in menu 'Dashboards'

Actual results:
Both are capable to provide the same functionality (jBPM Dashboard with jBPM related Key Performance Indicators) + item 2 has some extra administrative features for dashbuilder (if user has admin privileges)

Expected results:
There should be only 1 link from business central to dashbuilder application functionality. It should probably be #2, as it provides richer feature set.

Additional info:
Differences between 1) and 2)
1) - since it's integrated in business central, dashbuilder's administration bar is not displayed, thus majority of dashbuilder admin features is not displayed. Only 'jBPM Dashboard' available.

2) - has extra workspace 'Showcase', that is displayed for admin users. This workspace has some panels preconfigured, that enable some administrative features (e.g. ability do define external connections and queries to user specified databases etc.)
Comment 1 David Gutierrez 2013-09-16 12:19:11 EDT
We don't believe the "Business dashboards" link is redundant at all. The aim of "Business Dashboard" is to give the users access to the Dashbuilder's full set of features. In two modes:

* For administrators to create new dashboards and modify existing ones.
* For end users, to give them read-only access to existing dashboards.

With that in mind, We have changed the "Business dashboard" link in order to open the default Showcase dashboard instead of the jBPM Dashboard. 

Notice that the default Showcase could be easily modified by customers to provide ,for instance, a home page with links to the available dashboards.

So to sum up, just think about the Business Dashboard link as a gateway that leads the user to the Dashbuilder full feature set.


Github commit (master): https://github.com/droolsjbpm/kie-wb-distributions/commit/30c710c9d66fb5e089ba2da8a5f63a48332aeb79

Github commit (6.0.x): https://github.com/droolsjbpm/kie-wb-distributions/commit/45457ec7f817714257063013a912749dac1e4c9a
Comment 7 Jan Hrcek 2013-10-16 07:15:12 EDT
Ok, we agree with your justification, David.

It is currently also essential for testability of dashbuilder to have the Showcase workspace avaiable in the application, as it contains administrative features of the application preconfigured.

Verified with BPMS 6.0.0 ER4

Note You need to log in before you can comment on or make changes to this bug.