Bug 1007745 - Cannot unmount "stale" NFS handles
Cannot unmount "stale" NFS handles
Status: CLOSED DUPLICATE of bug 980088
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1007607
  Show dependency treegraph
 
Reported: 2013-09-13 05:06 EDT by John Schmitt
Modified: 2014-06-18 03:43 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 09:03:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Schmitt 2013-09-13 05:06:43 EDT
It doesn't seem to matter whether the soft or hard NFS mount option is used, it does not seem to matter that the connection to the NFS server is interrupted only temporarily.  No amount of umount -f, umount -l, et al seem to help.

This manifests itself even at shutdown.  The system that has the stale file handle will refuse to shutdown as it is busy continually unmounting and failing to unmount.
Comment 1 Jeff Layton 2013-09-16 09:03:34 EDT

*** This bug has been marked as a duplicate of bug 980088 ***

Note You need to log in before you can comment on or make changes to this bug.