Bug 1007751 - [RHS-C] warning: user ovirt does not exist - using root / warning: group ovirt does not exist - using root
[RHS-C] warning: user ovirt does not exist - using root / warning: group ovir...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-access-plugin-rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Keith Robertson
Prasanth
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 05:14 EDT by Prasanth
Modified: 2016-07-03 21:34 EDT (History)
16 users (show)

See Also:
Fixed In Version: redhat-access-plugin-rhsc-2.1.2-2.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously, during the installation of rhsc-setup RPM, benign warnings were displayed. Now, with this update, the warning is not displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:38:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
known issue (203.07 KB, application/pdf)
2013-09-13 12:47 EDT, Pavithra
no flags Details
known issue (203.07 KB, application/pdf)
2013-09-16 01:19 EDT, Pavithra
no flags Details
The fix is attached (1.17 KB, patch)
2013-11-25 06:14 EST, Bala.FA
no flags Details | Diff
Comment (282.14 KB, text/plain)
2013-09-13 05:14 EDT, Prasanth
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19212 None None None Never

  None (edit)
Description Prasanth 2013-09-13 05:14:09 EDT
Created attachment 915766 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Prasanth 2013-09-13 05:25:41 EDT
--------------
Installing : rhsc-setup-2.1.0-0.bb10.el6rhs.noarch
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
----------
Comment 3 Alon Bar-Lev 2013-09-13 06:29:35 EDT
There is no functionality lost if /var/lib/ovirt-engine/backups is owned by root.
Comment 4 Pavithra 2013-09-13 12:43:18 EDT
This was documented as a known issue in the 2.1 Release Notes
Comment 5 Pavithra 2013-09-13 12:47:59 EDT
Created attachment 797445 [details]
known issue
Comment 6 Pavithra 2013-09-16 01:19:41 EDT
Created attachment 798102 [details]
known issue
Comment 8 Alon Bar-Lev 2013-09-17 14:24:11 EDT
 Dusmant 2013-09-17 14:20:38 EDT
Assignee: dpati@redhat.comalonbl@redhat.com

Hi,

Any reason you set me as assignee?

Thanks,
Alon
Comment 9 Dusmant 2013-09-17 14:30:15 EDT
The spec file change to handle the ovirt user creation is going to be addressed in Corbett release. 

Release note is updated for the Big Bend release, which needs to be verified by QE
Comment 11 Scott Haines 2013-09-23 19:34:58 EDT
Targeting for 2.1.z U2 (Corbett) release.
Comment 12 Prasanth 2013-09-24 06:46:10 EDT
Bala, can you fill in the Fixed-in-version?
Comment 13 Bala.FA 2013-09-24 06:51:32 EDT
I updated 'Fixed in version' for Corbett.  For Big Bend, comment #7 is applicable.
Comment 14 Prasanth 2013-09-25 08:00:24 EDT
Verified as fixed in rhsc-2.1.1-0.0.1.master.el6ev.noarch
Comment 15 Shruti Sampat 2013-11-12 01:50:09 EST
Hi,

I am observing this issue in the latest RHSC build ( rhsc-2.1.2-0.23.master.el6_5.noarch ). The following is from the installatation logs - 

---------------------------------------------------------------------------

  Installing : rhsc-webadmin-portal-2.1.2-0.23.master.el6_5.noarch                                                                                                                                     319/326 
  Installing : rhsc-dbscripts-2.1.2-0.23.master.el6_5.noarch                                                                                                                                           320/326 
  Installing : rhsc-restapi-2.1.2-0.23.master.el6_5.noarch                                                                                                                                             321/326 
  Installing : redhat-access-plugin-rhsc-2.1.2-1.el6rhs.noarch                                                                                                                                         322/326 
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
warning: user ovirt does not exist - using root
warning: group ovirt does not exist - using root
  Installing : rhsc-setup-2.1.2-0.23.master.el6_5.noarch                                                                                                                                               323/326 
  Installing : rhsc-backend-2.1.2-0.23.master.el6_5.noarch                                                                                                                                             324/326 
  Installing : rhsc-tools-2.1.2-0.23.master.el6_5.noarch                                                                                                                                               325/326 
  Installing : rhsc-2.1.2-0.23.master.el6_5.noarch        

Moving the bug to ASSIGNED.
Comment 16 Bala.FA 2013-11-25 06:03:27 EST
This regression is due to redhat-access-plugin-rhsc.  As rhsc package depends on redhat-access-plugin-rhsc, at the time of installation ovirt user/group are not available and they are created/added by rhsc (sub)packages installation time.

The solution could be 

1) add ovirt user/group on %pre of redhat-access-plugin-rhsc (or)
2) using default user/group than ovirt user/group.  I am not sure whether this is correct or not.
Comment 17 Bala.FA 2013-11-25 06:14:03 EST
Created attachment 828603 [details]
The fix is attached
Comment 18 Prasanth 2013-12-16 14:45:36 EST
  Installing : rhsc-setup-2.1.2-0.27.beta.el6_5.noarch                                                                                                              324/326 
  Installing : rhsc-2.1.2-0.27.beta.el6_5.noarch                                                                                                                    325/326 
  Installing : redhat-access-plugin-rhsc-2.1.2-2.el6rhs.noarch                                                                                                      326/326 
rhel-65/productid
Comment 19 Prasanth 2013-12-18 07:27:55 EST
Verified as fixed in redhat-access-plugin-rhsc-2.1.2-2.el6rhs
Comment 20 Shalaka 2014-01-21 01:14:00 EST
Please review and signoff the edited DocText and signoff.
Comment 21 Keith Robertson 2014-01-21 05:59:59 EST
(In reply to Shalaka from comment #20)
> Please review and signoff the edited DocText and signoff.

DocText approved.
Comment 23 errata-xmlrpc 2014-02-25 02:38:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.