Bug 1007755 - Needs runtime dependency on perl(version)
Needs runtime dependency on perl(version)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-ExtUtils-MakeMaker (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1007775
  Show dependency treegraph
 
Reported: 2013-09-13 05:21 EDT by Paul Howarth
Modified: 2014-07-02 09:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: perl-ExtUtils-MakeMaker-6.76-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 09:19:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2013-09-13 05:21:39 EDT
Trying to update perl-NetAddr-IP to 4.070:

$ perl Makefile.PL
...
<snip>
...
Checking if your kit is complete...
Looks good
Can't locate version.pm in @INC (you may need to install the version module) (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/perl5/vendor_perl/ExtUtils/MM_Unix.pm line 2706.


$ rpm -qf /usr/share/perl5/vendor_perl/ExtUtils/MM_Unix.pm
perl-ExtUtils-MakeMaker-6.76-1.fc21.noarch
$ rpm -q --requires perl-ExtUtils-MakeMaker
/usr/bin/perl
perl >= 0:5.006
perl(:MODULE_COMPAT_5.18.1)
perl(AutoSplit)
perl(Carp)
perl(Config)
perl(Cwd)
perl(DirHandle)
perl(Exporter)
perl(ExtUtils::Command)
perl(ExtUtils::Install)
perl(ExtUtils::Installed)
perl(ExtUtils::Liblist)
perl(ExtUtils::Liblist::Kid)
perl(ExtUtils::MM)
perl(ExtUtils::MM_Any)
perl(ExtUtils::MM_Unix)
perl(ExtUtils::MM_Win32)
perl(ExtUtils::MY)
perl(ExtUtils::MakeMaker)
perl(ExtUtils::MakeMaker::Config)
perl(ExtUtils::Manifest)
perl(ExtUtils::Packlist)
perl(File::Basename)
perl(File::Find)
perl(File::Path)
perl(File::Spec) >= 0.8
perl(Getopt::Long)
perl(IO::File)
perl(Pod::Man)
perl(Test::Harness)
perl(lib)
perl(strict)
perl(vars)
perl(warnings)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Comment 1 Paul Howarth 2013-09-13 05:28:07 EDT
This issue is also present in perl-ExtUtils-MakeMaker-6.72-1.fc20
Comment 2 Petr Pisar 2013-09-16 02:21:19 EDT
I don't know how you run into this because fedpkg package run-requires 'perl(version)' transitively, but you are definitely right.
Comment 3 Fedora Update System 2013-09-16 03:37:02 EDT
perl-ExtUtils-MakeMaker-6.72-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-ExtUtils-MakeMaker-6.72-2.fc20
Comment 4 Fedora Update System 2013-09-16 04:11:27 EDT
perl-ExtUtils-MakeMaker-6.64-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-ExtUtils-MakeMaker-6.64-3.fc19
Comment 5 Fedora Update System 2013-09-16 04:20:52 EDT
perl-ExtUtils-MakeMaker-6.62-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-ExtUtils-MakeMaker-6.62-5.fc18
Comment 6 Paul Howarth 2013-09-16 05:12:07 EDT
(In reply to Petr Pisar from comment #2)
> I don't know how you run into this because fedpkg package run-requires
> 'perl(version)' transitively, but you are definitely right.

Doing a build for a local repo; I guess I may have a missing perl(version) dependency in one of my local packages that's superseding a Fedora version, which is what precipitated this bug.
Comment 7 Fedora Update System 2013-09-24 18:52:36 EDT
perl-ExtUtils-MakeMaker-6.72-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-09-24 19:01:55 EDT
perl-ExtUtils-MakeMaker-6.62-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-09-24 19:03:43 EDT
perl-ExtUtils-MakeMaker-6.64-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.