Bug 1007792 - Project screen: empty dependencies look like blank regions, not editable fields
Project screen: empty dependencies look like blank regions, not editable fields
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER1
: 6.0.1
Assigned To: manstis
Zuzana Krejčová
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-13 06:17 EDT by Zuzana Krejčová
Modified: 2014-08-06 15:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 15:58:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blank regions look of dependencies (12.03 KB, image/png)
2013-09-13 06:17 EDT, Zuzana Krejčová
no flags Details
screenshots with ER5 (45.24 KB, application/zip)
2013-12-10 04:15 EST, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-13 06:17:09 EDT
Created attachment 797259 [details]
blank regions look of dependencies

Description of problem:
See screenshot. If you add a dependency by clicking the Add button, you get a blank line with a trash icon on the right. It doesn't look editable - we need better interaction cues.
Comment 5 Zuzana Krejčová 2013-12-10 04:13:35 EST
I don't see how adding asterisks as placeholders for group, artifact, version improves anything, sorry. It doesn't make it look more editable.

You can look at the Project General Settings section of the project editor for better input fields and optionally at Deployments, Artifact Repository and other for an already-in-use look of item lists.
Comment 6 Zuzana Krejčová 2013-12-10 04:15:58 EST
Created attachment 834666 [details]
screenshots with ER5

I'm adding 3 screenshots to show what I'm talking about. The dependency section, the Project General Settings and the Artifact Repository, just to be sure.
Comment 7 Lukáš Petrovický 2014-02-04 12:49:08 EST
QE considers this optional for 6.0.1.
Comment 9 Lukáš Petrovický 2014-02-05 06:55:47 EST
Well, since the fix is already in... ;-)
Comment 10 Lukáš Petrovický 2014-02-07 11:19:17 EST
This no longer has a target release of 6.0.0.

Note You need to log in before you can comment on or make changes to this bug.