Bug 1007831 - CLI GUI - add operation for webservices client-config and endpoint-config fails
CLI GUI - add operation for webservices client-config and endpoint-config fails
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI (Show other bugs)
6.2.0
Unspecified Unspecified
medium Severity medium
: DR6
: EAP 6.3.0
Assigned To: Alexey Loubyansky
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 08:09 EDT by Petr Sakař
Modified: 2014-06-28 11:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous releases of JBoss EAP 6 an 'add' operation which did not have any arguments was treated as an operation that did not require any input from the user of the CLI GUI. This caused the user to be able to execute the operation without providing the required argument 'name' which would lead to a failure. In this release the 'add' operation without arguments is now treated by the GUI interface logic as one having required 'name' argument. Now, before allowing the user to execute an 'add' operation which in the management model description does not require any argument, the user will be prompted to provide the required 'name' argument.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:30:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sakař 2013-09-13 08:09:30 EDT
Description of problem:
CLI GUI lists client-config=* item in subsystem=webservices and offers user the operation add. Submit results in failure

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start AS
  ./jboss-eap-6.2/bin/standalone.sh &
2. open CLI gui
  ./jboss-eap-6.2/bin/jboss-cli.sh --gui &
3. click on subsystem=webservices, right click on client-config=*, select add operation and click on submit button

Actual results:
failure

Expected results:
either operation should not be offered to user, or dialog to fill in values should be provided - see subsystem=web connector=*


Additional info:

13:57:32,248 ERROR [org.jboss.as.controller.management-operation] (management-handler-thread - 11) JBAS014612: Operation ("add") failed - address: ([
    ("subsystem" => "webservices"),
    ("endpoint-config" => "*")
]): java.lang.IllegalArgumentException: JBAS014648: Cannot write to *
	at org.jboss.as.controller.OperationContextImpl.addResource(OperationContextImpl.java:650) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.OperationContextImpl.createResource(OperationContextImpl.java:619) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.AbstractAddStepHandler.createResource(AbstractAddStepHandler.java:101) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.AbstractAddStepHandler.execute(AbstractAddStepHandler.java:67) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:625) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:503) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.completeStepInternal(AbstractOperationContext.java:285) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.executeOperation(AbstractOperationContext.java:280) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.ModelControllerImpl.internalExecute(ModelControllerImpl.java:217) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.ModelControllerImpl.execute(ModelControllerImpl.java:134) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.remote.ModelControllerClientOperationHandler$ExecuteRequestHandler.doExecute(ModelControllerClientOperationHandler.java:194) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.remote.ModelControllerClientOperationHandler$ExecuteRequestHandler$1$2.run(ModelControllerClientOperationHandler.java:150) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.controller.remote.ModelControllerClientOperationHandler$ExecuteRequestHandler$1$2.run(ModelControllerClientOperationHandler.java:146) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_60]
	at javax.security.auth.Subject.doAs(Subject.java:415) [rt.jar:1.7.0_60]
	at org.jboss.as.controller.remote.ModelControllerClientOperationHandler$ExecuteRequestHandler$1.execute(ModelControllerClientOperationHandler.java:146) [jboss-as-controller-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.protocol.mgmt.AbstractMessageHandler$2$1.doExecute(AbstractMessageHandler.java:296) [jboss-as-protocol-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at org.jboss.as.protocol.mgmt.AbstractMessageHandler$AsyncTaskRunner.run(AbstractMessageHandler.java:518) [jboss-as-protocol-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_60]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_60]
	at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_60]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.1.Final-redhat-1.jar:2.1.1.Final-redhat-1]

{
    "outcome" => "failed",
    "failure-description" => "JBAS014749: Operation handler failed: JBAS014648: Cannot write to *",
    "rolled-back" => true
}
Comment 1 Petr Sakař 2013-09-13 08:14:01 EDT
the same applies for endpoint-config
Comment 2 Alessio Soldano 2013-09-19 12:11:24 EDT
This is basically a minor bug in the CLI GUI as confirmed by Stan.
The issue is to be fixed in https://issues.jboss.org/browse/WFLY-2114 .
Setting devel_ack to (-) for EAP 6.2 as there's an easy workaround here which is replacing the "*" with the name of the endpoint/client config in the generated command string. E.g.:

/subsystem=webservices/client-config=*/:add

becomes

/subsystem=webservices/client-config=FooConfig/:add
Comment 4 Stan Silvert 2014-02-14 08:54:25 EST
What am I acking?

Does someone intend to apply the fix or are we going to just suggest the workaround?

I'm fine with either decision, but I'd like to know what action we are taking.
Comment 8 Petr Kremensky 2014-04-01 07:14:35 EDT
Verified on EAP 6.3.0.DR6.

Both operations now offer user a dialog to fill in values and build correct command.

Note You need to log in before you can comment on or make changes to this bug.